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» Credits

What's new?

New in version 5.0

New user interface

The user interface has been completely redesigned using Developer Express VCL Components.
New in version 4.0

New editors

The table/view/virtual table editors have been completely redesigned using a new recursive-
descent parser based on COCO/R.

SQL Change script

The SQL change script is now available before applying changes to a database object:

-'Ef.'= 5QLite Expert Professional 5.0 (x86) = = &2
File View Database Import/Export Object SOL Transaction Scripting Tools Help
=1 (R Em 2 ] 000 5HE &S00 A A @E O ofice0iie [~
Database: dbdemos Table: orders File: C:\Data\sqlite\dbdemos.db3 SOLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FT55 RTREE]
v~ dbdemos J Database | Extensions | Schema | Data | DDL | Design ‘ SOL builder | sQL | Scripting |
ﬁ animals
E biolife J General | Columns | Primary Key | Indexes | Triggers | Foreign Keys | Unique Constraints | Check Constraints | Change Script \—
ﬁ clients 1 IPRAGHA [main] . foreign keys = "off"; -
E country =
3 SAVEPOINT [sglite_expert_apply design transaction];
E custoly 4
E customer 5 DROP INDEX [main].[idx orders CustMo];
ﬁ employee €
E events 7 ALTER TABLE [main].[orders] BRENAME TO [sgliteexpert temp table 1];
[ holdings 9 CREATE TABLE [main].[orders] (
E industry 10 [OrderNo] INTEGER PRIMARY KEY,
E items 11 [Custlo] INTEGER REFERENCES customer ([CustWo]l),
12 [SaleDate] DATETIME,
[ master : 13 [ShipDate] DATETIME,
[ nesteust : 14 [Emplo] INTEGER,
ﬁ CoiE 15 [ShipToContact] CHAR(Z0],
16 [ShipToRddrl] CHRR(30),
[ nextord 17 [ShipTolddr2] CHAR(30),
E orders 18 [ShipToCity] CHAR(13),
E parts 19 [ShipToState] CHAR({20),
ﬁ 20 [ShipToZip] CHAR({10),
(= 21 [ShipToCountry] CHAR{20},
E vendors 22 [ShipToFhone] CHRR(15),
[ venues 23 [ShipVIA] CHAR(7)},
= us 24 [PO] CHAR(LS),
=B 25 [Terms] CHAR (&),
26 [PaymentMethod] CHAR(7),
27 [TtemsTotal] CURRENCY, i
Apply Cancel
Modified - dick apply to save changes. il

New Dataset Export options

Export dataset to Open Document Spreadsheet (ODS).
Export dataset to SQL script.

64-bit version
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Starting with version 4.0, both 32-bit and 64-bit versions or SQLite Expert are now available for
both the Personal and Professional Editions.

Other features and changes

Experimental SQL formatter on the SQL and DDL tabs.

Database schema compare.

Settings are now stored in a JSON file.

Statically linked SQLite library is no longer included in version 4.0.

New in version 3.5

Improved license registration process

Added registration dialog in order to make the registration process more intuitive.

The license key is now stored in the common data folder as well, for better Windows 8
compatibility.

New license key format.

Documentation

Documentation is now included in both CHM and PDF format.

Other features:

Support for tables without rowid.
Support for partial indexes.

New in version 3.3

Support for virtual tables

Starting with version 3.3 SQLite Expert supports visual editing of virtual tables, including FTS3
and FTS4.

New in version 3.0

Printing support

Send the contents of any grid or editor to printer.
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r:ﬂu@m 3| ] 0w~ QB |E D E| W 41 of4 b M Close
customer
CustMNo Company Addr Addr2 City State Zip

1221|Kauai Dive Shoppe 4-976 Sugarloaf Hwy Suite 103 |Kapaa Kauai HI 94766-1234
1231|Unisco PO Box Z-547 Freeport
1351|Sight Diver 1 Meptune Lane Kato Paphos
1354|Cayman Divers World Unlimited [PO Box 541 Grand Cayman
1356|Tom Sawyer Diving Centre 632-1 Third Frydenhoj Christiansted  |St. Croix [00820
1380|Blue Jack Aqua Center 23-738 Paddington Lane [Suite 310[Waipahu HI 99776
1384|VIP Divers Club 32 Main St. Christiansted  St. Croix [02800
1510|Ocean Paradise PO Box 8745 Kailua-Kona HI 94756
1513|Fantastique Aguatica £32 999 #12A-TT A AL Bogota
1551|Marmot Divers Club 872 Queen St Kitchener Ontario |G3N 2E1
1560|The Depth Charge 15243 Underwater Fwy. Marathon FL 35003
1563|Blue Sports 203 12th Ave. Box 746 Giri baldi OR 91187
1624|Makai SCUBA. Club PO Box 8534 Kailua-Kona HI 94756
1645 |Action Club PO Box 5451-F Sarasota FL 32274
1651|Jamaica SCUBA Centre PO Box 68 Negril Jamaica
1680|Island Finders 6133 1/3 Stone Avenue St Simons Isle [GA 32521
1984 |Adventure Undersea PO Box 744 Belize City
2118|Blue Sports Club 63365 Nez Perce Street Largo FL 34684
2135|Frank’s Divers Supply 1455 Morth 44th St Eugene oR 90427
2156(Davy Jones' Locker 246 South 16th Place Vancouver BC Kav 9P1

A

Page 1of4

REEU)‘ MECOTa 1 0T 22
Skins library

Customize the look and feel of the application using skins. In version 4.0, skins have been replaced

with VCL Styles:
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SQLite library

New in version 2.0

Improved Unicode support

At first glance, version 2.0 is not much different from the latest version 1.7. However, version 2.0
brings major internal improvements with respect to Unicode support. SQLite Expert is written in
Delphi, and Delphi versions older than 2009 did not include native Unicode support. SQLite
Expert versions 1.x included Unicode support by using a freeware library - UTF8§VCL available
from SourceForge. This project was in alpha stage of development and seems to be currently
unmaintained.

The latest version of Delphi (Delphi 2009) finally added complete support for the Unicode
character set, so it was the logical choice to upgrade the source code of SQLite Expert to Delphi
2009. This process took a few months because of the major internal differences between the two
compilers. During this migration, the source code was gradually modified to compile with Delphi
2009 while still being compatible with Delphi 2007. As a result of this process, versions 1.7 and
2.0 of SQLite Expert look very similar but are actually much different internally. The native string
type in Delphi 2007 was the AnsiString while in Delphi 2009 it is the UnicodeString (using UTF-
16 encoding).

The following differences between versions 1.7 and 2.0 are related to the improved Unicode
support:

1. The default type mapping for CHAR and TEXT is now WideString instead of String. That
means, all the text is now converted to UTF-16 when it is loaded from the database. In version 1.x
it was converted to UTF-8. It is recommended not to change this setting.



2. It you wish to change the default type mappings for other declared types so they are handled
internally as strings, you should map them to WideString, not to String as in version 1.x.

3. More encoding options on import/export from/to text files. An encoding detection when
importing a text file has been included that seems to work reasonably well in most cases.

4. The Encoding options have been renamed to "Unicode (UTF-8, UTF-16)" and "Default ANSI
code page".

Statically linked sqlite3 library

Starting with version 2.0, SQLite Expert includes a statically linked sqlite3 library, so it can be
used without an external sqlite3.dll. However, it is still possible to use an external library, which
might be a useful feature in case you want to use a more recent sqlite library, or one that supports
encryption (note that encryption support is only available in the Professional Edition).

No bug fixes between 1.7 and 2.0

During the migration from Delphi 2007 to Delphi 2009, all the bug fixes have been implemented in
both versions 1.7 and 2.0, so if a bug exists in the latest 1.7 version and is not Unicode related,
there is a good chance it is still present in version 2.0. However, at the time of the 2.0 released, all
the reported bugs have been fixed. Also, after the release of 2.0 no more bug fixes will be
implemented in 1.7, so it is recommended to upgrade to version 2.0 to keep up with the latest
updates.

What is SQLite?

What is SQLite?

SQLite (www.sqlite.org) is a small C library that implements a self-contained, embeddable, zero-
configuration SQL database engine. Features include:

( Transactions are atomic, consistent, isolated, and durable (ACID) even after system crashes
and power failures.

( Zero-configuration - no setup or administration needed.

( Implements most of SQL92.

( A complete database is stored in a single disk file.

( Database files can be freely shared between machines with different byte orders.
( Supports databases up to 2 terabytes (241 bytes) in size.

( Sizes of strings and BLOBs limited only by available memory.

( Small code footprint: less than 250 kB fully configured or less than 150 kB with optional
features omitted.


http://www.sqlite.org/

SQLite Expert 5.5

( Faster than popular client/server database engines for most common operations.

( Simple, easy to use API.

( TCL bindings included. Bindings for many other languages available separately.

( Well-commented source code with over 95% test coverage.

( Self-contained: no external dependencies.

( Sources are in the public domain. Use for any purpose.

What is SQLite Expert?

SQLite Expert version 5.0

SQLite Expert is a powerful visual tool that enables you to easily administer your SQLite 3
databases and gain significantly better visibility into how your databases are operating. SQLite
Expert integrates database management and maintenance into a single, seamless environment, with
a clear and intuitive graphical user interface.

u!_‘: 5QLite Expert Professional 5.0 (x86) = = &2
File View Database Import/Export Object SOL Transaction Scripting Tools Help
GGaGHE - 1CREHRIFLRLGY BRI v Q00 S5EE S0 A A @ O office0islue v
Database: dbdemos Table: animals File: C:\Data\sqlite'dbdemos.db3 SOLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FT55 RTREE]
~3 dbdemns J Database | Extensions | Schema | Data | DDL | Design | SOL builder | saL | Scripting |
E Mo 4 B W+ = & o XA %k E Refresh
] clients owid | NAME |size |WEIGHT  |AREA Bmp | -
E country 7 Click here to define a filter
E custoly 3 1| Angel Fish | 2 2 Computer Aquariums | ‘:.E;- |
E customer 2/ Boa 10 8 South America m
ﬁ employee 3 Critters 30 20 Screen Savers ﬁ
E events 4 House Cat 10 5 New Orleans m
™ holdings 5 Ocelot 40 35 Africa and Asia ) =
[T industry 6 Parrot 5 5 South America
E e | 7 Tetras 2 2 Fish Bowls
E master
E nextcust
ﬁ nextitem
E nextord
ﬁ orders
E parts
ﬁ reservat
E vendors
[ venues
E Wapia
<Filter is Empty> Customize... -
Ready i

Features include:

( Edit tables and views visually, mostly without writing a line of SQL. Easily restructure fields,
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foreign keys, indexes, constraints, triggers without losing data already existing in the tables. Copy
fields, foreign keys, indexes, constraints and triggers between tables using the clipboard.

( Build SQL scripts and generate views visually using the integrated Query Builder.

( Access encrypted databases (Professional Edition).

( Create SQLite3 databases, view and change database parameters, check database integrity and
vacuum (compact) database.

( Import or Export data from/to SQL script, another SQLite database, ADO data sources, text files,
or Excel.

( Display and edit data in the grid, including BLOB and image fields. Currently supports BMP,
JPG, PNG, GIF and ICO image formats. BLOB fields can be edited with the integrated hex editor.
Copy records between tables using the clipboard. Copy tables and views between databases using
the clipboard or using drag and drop operations.

( Execute SQL queries. Supports multiple SQL statements in the same query.

( Attach and detach databases.

( Cancel the execution of long-running SQL scripts.
( In-grid editing of live queries.
( Save/Load SQL scripts to/from file.

( Transaction support. SQLite supports nested transactions starting with version 3.6.8.

( Data mapping. SQLite Expert supports custom data types, and 40 predefined data types.

( Extend SQLite Expert capabilities using Lua and Pascal scripting.

Starting with version 1.1.4, SQLite Expert is available in two flavors: Personal Edition
(freeware) and Professional Edition (shareware). The content of this help file applies to the
Professional Edition. For a comparison between the Personal and Professional editions please
see the Feature Matrix available on the SQLite Expert homepage.

Feature comparison

| Personal | Professional

General

Customize the appearance of the application using skins ] ]
Send the contents of any grid to printer or export it to a PDF file ]
Managing SQLite3 databases

Create database ] )
View and change database parameters @ @
Register frequently used databases for using in SQLite Expert ] <@
Check integrity @ ]

11/124
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Personal

Professional

Vacuum

Reindex all tables

Transaction support

Supports attached databases

Supports encrypted databases

Supports SQLite extensions

LI (A<

Supports SQLite auto extensions

Includes ICU extension

View database schema report

Export to Excel, ODS

Export to XML, HTML, JSON

Import and export from and to text files (CSV, TSV)

Import data from ADO data source

Transfer data between SQLite databases

Export data to SQL script

Database DDL compare tool

Online backup of a database

CIOICICICCICICIC 00000 0ECE

Managing tables

Create tables

Delete tables

Rename tables

Reindex tables

Restructure tables without losing existing data

View, add, delete, modify, reorder fields

Copy/Paste fields via clipboard

View, add, delete, modify foreign keys

Copy/Paste foreign keys via clipboard

View, add, delete, modify indexes

Copy/Paste indexes via clipboard

View constraints

Add, delete, modify constraints

Copy/Paste constraints via clipboard

View triggers

Add, delete, modify triggers

Copy/Paste triggers via clipboard

Supports temporary tables

Supports virtual tables including RTREE, FTS3 and FTS4

CECCCCCICCICCICICIEC 0000

CIEICICICICICICICICICLICIECI0ICICE

Managing views

Create views

Delete views

L
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Personal

Professional

Rename views

View triggers

LS

Add, delete, modify triggers

Copy/Paste triggers via clipboard

Supports temporary views

(L (<

L

Executing SQL scripts

Execute SQL scripts

Stop long running queries

SQL code formatting (experimental)

SQL syntax highlighting

SQL Code Completion

Save and load SQL scripts

Supports parameters in SQL scripts

CIGIGIC|ICICIC

CICICICICICIC

Query Builder

Visual building of complex SQL queries

User-friendly interface with drag & drop support

Visual building of sub-queries and unions

Visual criteria constructing tool for Where and Having clauses

Save and load SQL scripts

CIGICC|IC

Displaying and editing data

Display and edit data in the grid

Display data as text

Data filtering

Image editor (supports BMP, JPEG, PNG, GIF and ICO)

BLOB editor

Text editor

Copy/Paste records between tables via clipboard

COIGICCCC

Copy/Paste tables between databases via clipboard

Copy tables between databases using drag and drop

Generate HTML Reports

CICICICIC0CICICIC

Extending SQLite Expert using scripting

Lua scripting support

Pascal scripting support

Lua and Pascal example scripts

Data types

40 predefined data types

Custom data types

LS

LS
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Terms and Conditions

SQLite Expert Terms and Conditions

Last Updated: Oct 30, 2024

Thank you for choosing SQLite Expert. By downloading, installing, and using SQLite Expert
(“Software”), you agree to be bound by the following Terms and Conditions. Please read them
carefully.

1. Acceptance of Terms

By accessing or using SQLite Expert, you confirm that you have read, understood, and agree to
abide by these Terms and Conditions. If you do not agree, you may not use the Software.

2. License - Personal Edition

This Software is being distributed as Freeware. It may be freely used, copied and distributed as
long as it is not sold, and all original files are included, including this license. You are NOT
allowed to make a charge for distributing this Software (either for profit or merely to recover your
media and distribution costs) whether as a stand-alone product, or as part of a compilation or
anthology, without explicit prior written permission.

3. License - Professional Edition

3.1. License Grant

Subject to the terms and conditions outlined herein, Coral Creek Software grants you a non-
exclusive, non-transferable license to use SQLite Expert solely for your internal purposes. You
may install and use the Software according to the licensing terms purchased.

3.2. License Restrictions

You shall not:

Copy, modify, distribute, or create derivative works based on the Software.

Reverse engineer, decompile, disassemble, or otherwise attempt to derive source code from the
Software.

Rent, lease, lend, or sublicense the Software.

4. Subscription and Fees

SQLite Expert is offered on a subscription basis. By subscribing, you agree to pay the subscription
fees as outlined at the time of purchase. Subscription fees may vary based on license type and
additional features.

4.1. Automatic Renewal

Your subscription may automatically renew at the end of each term unless canceled or switched to



manual renewal. You may cancel your subscription anytime by contacting our support team or
managing your account through the provided portal.

4.2. Refund Policy

Our 30-day refund policy allows customers to request a full refund within 30 days of purchase if
they are not fully satisfied with our product. To qualify, customers must provide a valid purchase
receipt and describe any issues they encountered. Refunds will be issued to the original payment
method within 7-10 business days of approval. After 30 days, refunds are not available.

5. Intellectual Property

SQLite Expert, including but not limited to all software, documentation, trademarks, and other
proprietary materials, is the exclusive property of Coral Creek Software. These Terms and
Conditions do not grant you any ownership rights, and you agree not to use or reproduce any Coral
Creek Software trademarks without permission.

6. Privacy

Your privacy is important to us. Please refer to our Privacy Policy for information on how we
collect, use, and disclose your data.

7. Updates and Support
7.1. Software Updates

We may, at our discretion, provide updates or upgrades to the Software to improve functionality,
security, or performance. You agree to install such updates to ensure optimal use of SQLite Expert.

7.2. Support

Technical support is provided to users with an active subscription. Support requests can be
submitted through support@sqliteexpert.com.

8. Disclaimer of Warranties

The Software is provided “as is,” and Coral Creek Software makes no warranties, express or
implied, regarding the Software. This includes but is not limited to implied warranties of
merchantability, fitness for a particular purpose, and non-infringement.

9. Limitation of Liability

To the fullest extent permitted by applicable law, Coral Creek Software shall not be liable for any
damages, including but not limited to direct, indirect, incidental, consequential, or punitive
damages arising from the use of or inability to use the Software, even if advised of the possibility
of such damages.

10. Termination

This license is effective until terminated. You may terminate this agreement at any time by ceasing
all use of and deleting all copies of the Software. Coral Creek Software reserves the right to

terminate this license if you breach any terms herein.

11. Governing Law



These Terms and Conditions are governed by and construed in accordance with the laws of
Florida, United States. Any disputes arising under these Terms and Conditions shall be subject to
the exclusive jurisdiction of the courts located in Escambia County, Florida.

12. Changes to Terms and Conditions

Coral Creek Software reserves the right to update or modify these Terms and Conditions at any
time without prior notice. Continued use of the Software after modifications are posted constitutes
acceptance of the revised Terms and Conditions.

If you have any questions or concerns regarding these Terms and Conditions, please contact us at
support@sqliteexpert.com.

ICU License
ICU License - ICU 1.8.1 and later

COPYRIGHT AND PERMISSION NOTICE
Copyright (¢) 1995-2014 International Business Machines Corporation and others
All rights reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this
software and associated documentation files (the "Software"), to deal in the
Software without restriction, including without limitation the rights to use, copy,
modify, merge, publish, distribute, and/or sell copies of the Software, and to permit
persons to whom the Software is furnished to do so, provided that the above
copyright notice(s) and this permission notice appear in all copies of the Software
and that both the above copyright notice(s) and this permission notice appear in
supporting documentation.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY
KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO
EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS
NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR
CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER
RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION,
ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
OF THIS SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used
in advertising or otherwise to promote the sale, use or other dealings in this
Software without prior written authorization of the copyright holder.



All trademarks and registered trademarks mentioned herein are the property of their
respective owners.

Ordering

Register online

You may use SQLite Expert free of charge while evaluating it. The evaluation period is limited to
30 days. After the expiration of the evaluation period you must either buy this software or remove
it from your computer.

Software registrations are currently handled by FastSpring, a company that specializes in software
registrations. All ordering pages are on secure SSL servers, ensuring safety of your confidential
information. All major credit cards are accepted.

To order select Help » Buy Online or visit www.sqliteexpert.com/order.html and follow the
instructions on the page.

After your order has been processed you will receive a license key file by email. To complete the
registration process, copy the license file in the installation directory.

System requirements, installation and registration

System Requirements

Operating System: Windows 2000/XP/2003/Vista/7/8/10/11;
Installation

In order to install SQLite Expert, download and run SQLiteExpertSetup.exe and follow the on-
screen instructions. The setup program will ask you to select options and where to install SQLite
Expert. If you are unsure, you should accept the defaults.

Once installed, you can start SQLite Expert from the Start Menu.

Note:
You need to have administrator rights to install SQLite Expert.
To see if you are logged on to Windows as an administrator, please follow the steps below:

1. From your Windows taskbar, click "Start" > "Run."

2. Type [ control userpasswords2 ] into the text box and click "OK."

3. A User Accounts dialog box will open. If the dialog box has two tabs, you are logged in as an
administrator. If the dialog box doesn't have any tabs and prompts you for a password, you are not
logged in as an administrator.


www.fastspring.com
http://www.sqliteexpert.com/order.html/

If you do not have administrator rights on your computer, please contact your system
administrator.

Registration

After purchasing and receiving the license key, register by selecting the Help » Register option
from the main menu and following the instructions on the screen.

Credits

Credits

SQLite Expert is Copyright © 2024 Coral Creek Software.

This program contains or uses the following software components:

( DevExpress VCL Components (http://www.devexpress.com/)

( Virtual Treeview by Mike Lischke (http://www.soft-gems.net/)

( SynEdit 2.0.1 beta by Michael Hieke (http://synedit.sourceforge.net)

( TMPHexEditor © Markus Stephany (http://www.mirkes.de/)

( Inno Setup © 1997-2005 Jordan Russell (http://www.jrsoftware.org/)

( The FastCode Project (http://fastcode.sourceforge.net/)

( FastMM by Pierre le Riche (http://sourceforge.net/projects/fastmm/)

( Vcl-Styles-Utils by Rodrigo Ruz (https://code.google.com/p/vcl-styles-utils/)

Using SQLite3 databases

Creating and editing SQLite3 databases, and other commands for working with databases.

» Creating databases

» Opening an existing database

» Closing a database

» Editing database registration
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» Displaying database information and internal parameters

» Performing maintenance operations

» Using encrypted databases

» Attaching and Detaching databases

» Loading and Unloading SQLite extensions

» Comparing the DDL of two databases

» Performing an online backup of a database

Creating databases
To create a new SQLite3 database, select
File » New Database

You will be prompted to select the file name and alias for the new database. Additional
parameters can be set on the Database tab.

SQLite Expert will choose a default alias for the database, but you can change it according to your
preferences. You can enter any name for the alias, as long as it is not already used. After entering

the desired parameters, the database will be created in the specified directory and it will show in
the tree panel.

Tips

After immediately creating a SQLite database and before any tables are created, a SQLite database
is a single file having a size of 0 bytes. At this point, no information has been written on disk. If
you close and re-open SQLite Expert, the program will ask which is the desired encoding for the

database. After creating the first table, the encoding setting is persisted into the database and
cannot be changed.

Opening an existing database

To open a SQLite3 database, select

File » Open Database

or

File » Open Recent Database

from the main menu. You will be prompted to select the file name for new database. After selecting
a file name, the database will show in the left tree panel. SQLite Expert will choose a default alias

for the database, but you can change it according to your preferences.

SQLite Expert will automatically connect to the database so you will see all the tables and views
in the left tree panel.
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You can also drop SQLite database files (with .db3 or another registered extension) from the
Windows environment in the left tree panel.

Closing a database

To close and unregister a SQLite3 database, select

File » Close Database

This will close the connection to the database and will remove it from the left tree panel.
Renaming database alias

To change the alias for a SQLite3 database, select it in the tree panel and then select
File » Rename Database Alias

You will be prompted with a dialog that will allow you to change the database alias.
Displaying database information and internal parameters

In order to view or change the properties of the selected database, click on the Database tab.

q: 50Lite Expert Professional 5.0 (x86) o [BOE
File View Database Import/Export Object SOL Transaction Scripting Tools Help
== g S S L [, B b wem — N ™ = - DA LT = -
GGaEGHE - GREHELDG @GN OGN Gy Q00 S EEEE S EE A A @ F @) 0ficew08.
Database: dbdemos Table: animals File: C:\Data\sqlite\dbdemos.db3 5QLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FTS5 RTREE]
v—[J dbdemos J Database ‘ Extensions | Schema | Data | DDL | Design | SOL builder | saL | Scripting |
Databases
[ biolife
E clients Database |Status |F\Ie Name |Fi|e Size |Tables Views Indexes Triggers
A country ¥ |main Connected C\Data\sqglite\dbdemos.db3 3770368 21 0 21 0
ﬁ custoly
E customer I
E employes Database properties Library/Session/Connection properties
E events MName |\u’a|ua |Modified ‘A Name |\u‘a|ue |Modified |A
ﬁ heldings ¥ |application_id 0 ¥ |automatic_index |on
E industry auto_vacuum none busy_timeout 3000
E items cache_size 2000 cache_spill 2000
E master collation_list [BINARY], [MAMES], [NOCASE], [NL = case_sensitive_like off 3
E eI CiET encoding UTF-8 cell_size_check off
E T foreign_keys on checkpoint_fullfsync off
freelist_count 113 compile_options [COMPILER= mswvec-1800], [D
E nextord P P
journal_mode delete data_version 2
ﬁ orders = |
E ” Jjournal_size_limit -1 defer_foreign_keys off
arts — H
5 legacy_file_format off fullfsync off
[ reservat =i IRE
max_page_count 1073741823 ignore_check_constraints off
ﬁ vendors H . u z
ﬁ mmap_size 0 locking_mode normal
venues page_count 3682 query_only off
E Wapia B . |
page_size 1024 read_uncommitted off
schema_version 257 recursive_triggers off
user_version 0 - reverse_unordered_selects off -
<2 Apply X Cancel [3 Refresh [& Check (4 Vacuum 5 Reindex All Tables [ Repair [uzy Backup
Ready

The Databases grid displays information about each of the internal databases ([main], [temp] and
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the attached databases if any).

The following information is available:
( File name for each database except [temp]
( File size in bytes for each database except [temp] or :memory: databases
( Number of tables in the database
( Number of views in the database
( Number of indexes in the database
( Number of triggers in the database

( Status for the [main] database (connected, disconnected, encrypted, unavailable)

The grid in the lower left part of the screen displays the properties of the selected database in the
Databases grid, in a master-detail relationship. These properties are persistent in the database.

The grid in the lower right part of the screen displays the library/session/connection properties of
the selected database in the Databases grid, in a master-detail relationship. These properties are
not persistent in the database.

These properties can be queried or set using PRAGMA commands. To modify the value of a
property, press ENTER or double-click on the record, enter the new value and then click the
Apply button.

Additionally, the following commands are available:

( Integrity check: performs a "pragma integrity check" in the selected database.
( Vacuum: performs a "vacuum" in the [main] database.

( Reindex: reindexes all tables in the selected database.

( Repair: repair a corrupted database.

( Backup the selected database.

Note: not all properties can be set or queried. For example, the encoding can only be set
immediately after the creation of a database, and before any tables have been created. For more
information see the Pragma commands in the SQLite documentation.


http://www.sqlite.org/pragma.html
http://www.sqlite.org/pragma.html

Performing maintenance operations

Checking database integrity

To perform an integrity check for a SQLite3 database, select it in the tree panel and then select
Database » Check

This will execute an internal pragma integrity check command. According to the SQLite
documentation, this command does an integrity check of the entire database. It looks for out-of-
order records, missing pages, malformed records, and corrupt indices. If any problems are found,

then a single string is returned which is a description of all problems. If everything is in order,
"ok" is returned.

Performing a database Vacuum

To perform a database vacuum, select

Database » Vacuum

This will execute an internal vacuum command. According to the SQLite documentation, this
command cleans the main database by copying its contents to a temporary database file and
reloading the original database file from the copy. This eliminates free pages, aligns table data to

be contiguous, and otherwise cleans up the database file structure.

For a detailed description of the vacuum command, please see the SQLite3 online documentation.

Reindexing all the tables in the database

To reindex all the tables in the database, select

Database » Reindex All Tables

Repairing a database

To repair a damaged database, select

Database » Repair



This will pop up the database repair dialog:

£ Repair database = 3

Destination
Same file

o Mew file: ChData\sglite\dbdemos_repaired.db3

Leg

Cloze

It is recommended to choose the option to repair the database in a new file in order to preserve the
old database. Click the Start button to start the repair process. SQLite Expert will create a new
database and will try to copy as much data as possible in the new database. There is no guarantee
that all the data will be recovered.

Using encrypted databases

SQLite Expert Professional supports encrypted databases if an SQLite library with encryption
sypport is provided. For legal reasons, an SQLite library with encryption support is currently not
included in the distribution.

You can select which SQLite library DLL to use in Tools/Options/SQLite Library. This section
displays a list of the SQLite library DLLs found in the installation directory. If you wish to use a
SQLite library other than the default one included with the distribution, just copy it in the
installation directory and then select it in Tools/Options/SQLite Library. For encryption support,
the following libraries are available as freeware or commercial products:

SQLCipher - open source


http://sqlcipher.net/

System.Data.SQLite - public domain, includes a SQLite library with encryption support -
SQLite.Interop.dll. This library is compatible with the sqlite3crypt.dll included with older
versions of SQLite Expert.

The SQLite Encryption Extension (SEE) - commercial

The Free SQLite Encryption Extension (FSEE) - open source

The following operations are available from the database tree popup menu when using a library
that supports encryption:

( Set an encryption key to a database that was previously unencrypted. This will encrypt the
database using the provided encryption key.

(  Enter the encryption key for accessing an encrypted database. This option allows access to
the database, but does not modify its content.

(  Enter a new key for an encrypted database. This option will re-encrypt the database using
the new encryption key. For removing the encryption on a database, just enter an empty
encryption key.

(  Enter default encryption key. This is a key that will be tried first for all the encrypted
databases.

If you wish SQLite Expert to remember the encryption keys between sessions (including the default
encryption key), check the option Remember encryption keys in Tools/Options/General/Startup. In
this case SQLite Expert will store the (encrypted) encryption keys with the settings. This option is
less secure and is disabled by default.

Attaching and Detaching databases

Attaching and detaching databases can be performed using the ATTACH and DETACH SQL
commands, or using the user interface commands.

To attach another database to an existing database connection, select
File » Attach Database

You will be prompted to select the file name and alias for the new database. If the attach operation
is successful, the tables and views in the attached databases will be displayed in the tree being
prefixed with the database alias.

You can also drop SQLite database files (with .db3 or another registered extension) from the
Windows environment in the left tree panel while pressing the SHIFT key. The dropped databases
will be attached to the current database.

To detach an attached database, select

File » Detach Database


http://system.data.sqlite.org/index.html/doc/trunk/www/index.wiki
http://www.hwaci.com/sw/sqlite/see.html
https://github.com/shenghe/FreeSQLiteEncryption

then select the desired database from the list of the existing attached databases.

SQLite Expert remembers attached databases between sessions. At program startup, it will attempt
to attach the databases that were attached at the end of the previous session.

Loading and Unloading SQLite extensions

Loading and Unloading SQLite extensions

To load an SQLite extension in the selected database, select

Load Extension

from the left panel drop-down menu.

You will be prompted to select the file name and the entry point for the new database, and also if
the extension should be registered as an Auto-extension. If the operation is successful, the functions

defined in the extension will be available for usage in SQL expressions in the selected database.

If the Auto option is selcted, the extension will be registered using the sqlite3 _auto_extension()
API and will be loaded for each new database connection, but not for the existing connections.

Loading an SQLite extension can also be performed using a SELECT LOAD_EXTENSION
command. However, when loading an extension using the Load Extension menu item, this
operation is performed by calling the sqlite3_load extension() APL

Note: when loading a SQLite extension, make sure it is compiled for the same platform as SQLite
Expert, i.e. SQLite Expert x64 will only load 64bit SQLite extensions.

To unload an extension, select

Unload Extension

from the left panel drop-down menu, then select the desired extension from the list of the existing
loaded extensions for the selected database. Unlike extension loading, there is no SQL command

for unloading an extension. Therefore, in order to unload an extension, SQLite Expert is closing
and reopening the selected database.

SQLite Expert remembers loaded extensions between sessions. At program startup, it will attempt
to load the extensions that were loaded in the previous session.

Viewing the loaded SQLite extensions


http://www.sqlite.org/c3ref/load_extension.html
http://www.sqlite.org/c3ref/auto_extension.html
http://www.sqlite.org/c3ref/auto_extension.html
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At any moment, a list of the SQLite extensions currently loaded is displayed on the Extensions tab.
For each extension, a list of the included functions and collations is also displayed.

'/ SOLite Expert Professional 5.0 (x86)

File View Database Import/Export Object 501 Transaction Scripting Tools Help

05662 G GEGRERE @ B w000 (5 E 5 Eis S B A @EO

Database: dbdemos Table: animals  File: C\ProgramDatat\5C0Lite Expert\Professional 5 - 32bit\Data\dbdemos.db3 5QLite library: sqlite3.dll 3.19.3 [FT53 FT54 FT55 RTREE]
o Coee,
- s 1. S
_m country H C\CCSoftDX\Source!\Projects\SOLiteExtensions\unifuzz.dll sqlited_extension_init
—m custoly
—E customer
] e e ———— ——————— ———————————————
e T —
-~ rings T e e M ——Te e e |
75 industry sqlite3_create_function 1 sqlite3_create_collation UTF16-LE
75 items |_| lower sqlite3_create_function UTF-8 1 sqlite3_create_collation UTF16-LE
_E master |_| like sqlite3_create_function UTF-8 2 |_| UMACCENTED sqlite3_create_collation UTF16-LE
_m nextcust |_| like sqlite3_create_function UTF-8 3 |_| MUMERICS sqlited_create_collation UTF16-LE
_m R |_| glob sqlited_create_function UTF-8 2
_E Do |_| upper sqlite3_create_function UTF-16 1
_E pickcr |_| lower sqlite3_create_function UTF-16 1
:E parts t |_| like sqlited_create_function UTF-16 2
75 :?:::r; |_| like sqlite3_create_function UTF-16 3
75 venues |_| glob sqlited_create_function UTF-16 2
L wapia | title sqlite_create_function  UTF-8 1

|_| fold sqlite3_create_function UTF-8 1
|_| flip sqlite3_create_function UTF-8 1

unaccent sqlited_create_function UTF-8 1
|_| proper sqlite3_create_function UTF-8 1
|_| typos sqlited_create_function UTF-8 2
|_| ascw sqlited_create_function UTF-8 1
| | ascw sqlite3_create_function UTF-8 &

Ready |

Comparing the DDL or Schema of two databases
To compare the DDL of two databases, follow the steps below:

1. Select Tools » Database DDL. Compare

from the main menu.

2. Select the first and second database.
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Previous changes Mext changes |lgnerecase Ignore whitespace

Select First Databasze: |dbdemos Select Second Database: |dbdemos(1]

1 CREATE TRBLE [animals] ( 1 CREATE TRBLE [animals](

2 [NAME] CHAR (10}, 2 [NAME] CHER {10},

3 [SIZE] INTEGER, 3 [SIZE] INTEGER,

4 [WEIGHT] INTEGER, 4 [WEIGHT] INTEGER,

5 [AREA] CHER(20), 5 [AREA] CHER(20),

6 [BMP] BLOB): [ [BMF] BLOE);

T T

g CREATE TRBLE [bioclife] ( § CREATE TRBLE [biclife] |
g [Species No] INTEGER PRIMARY KEY, §  [Species No] INTEGER PRIMARY KEY,
10 [Category] CHRR(13), 10 [Category] CHAR(15),

11 [Common_Name] CHAR (30), 11  [Common_Name] CHAR(30),
12 [Species Name] CHRE (40}, 12 [Species Name] CHRR({40),
13 [Length (cm)] FLOAT (0, 2}, | 13] (Length {em] FLOAT{(0, 2},
14 [Length_In] FLOAT(0, 2), 14 [Length In] FLOAT (0, Z),
15 [Notes] CHAR, 15 [Hotes] CHAR,

16 [Graphic] GRAPHIC); 16 [Graphic] GRRPHIC);

17 17

18  CRERTE TRBLE [clients] { 18 CREATE TABLE [clients] |
19 [LAST NAME] CHAR({Z0), 1% [LAST NAME] CHAR({20),
20 [FIRST_NAME] CHER({20), 20 [FIRST_NAME] CHAR(20),
21 [ACCT _NER] INTEGER, 21  [ACCT_NBR] INTEGER,

22 [ADDRESS_1] CHAR({20), 22 [ADDRESS_1] CHAR({20),
23 [CITY] CHRR(20), 23 [CITY] CHAR({20},

24 [STATE] CHLR(Z), 24 [STATE] CHRER(Z),

25 [ZIF] CHAR(5), 25 [ZIP] CHRR(S),

] ———SSSSS——

|| Matches: 247

| Modified: 7

| Added: 2

| Deleted: 0

s |(E[EN

To compare the schema of two databases, follow the steps below:

1. Select Tools » Database Schema Compare

from the main menu.

2. Select the first and second database.

271124



SQLite Expert 5.5

Previous changes Mext changes Ignore case Ignore whitespace
Select First Databasze: |dbdemos Select Second Database: |dbdemos(1]
1 Database: [dbdemos] 1 Database: [dbdemos(l)]
& File name: C:\ProgramData‘\S{QLite Expert\Profe: i File name: C:\Data\sglite\dbkdemos.db3
3 File size: 3673088 bytes 3 File size: 3770368 bytes
4 Page szize: 1024 4 Page s3ize: 1024
3 Encoding: UTF-8 5 Encoding: UTF-8
6 Auto wvacuum: 0 [ Auto vacuum: 0
7 Tables: 22 7 Tables: 22
g Views: 0 g Views: 0
g Virtual Tables: 0 g Virtual Tables: 0
w —-——m————————— -
11 Takle [animals] 11 Takle [animals]
12 Fields: 35 12 Fields: 5
13 [NAME]: CHRR(10) 13 [NAME]: CHAR({10)
14 [SIZE]: INTEGER 14 [SIZE]: INTEGER
15 [WEIGHT]: INTEGER 15 [WEIGHT]: INTEGER
16 [ARER]: CHAR(Z0) 16 [RRER]: CHAR(Z0)
17 [EMF]: BLOB 17 [EMP] : BLOB
18 Indexes: 1 18 Indexes: 1
19 [idx animals_ NAME] 19 [idx animals NAME]
20 [NEME] 20 [NAME]
21 Triggers: O 21 Triggers: O
22 Takle constraints: 22 Table constraints:
23 Primary Key: 23 Primary Key:
24 Fields: 24 Fields:
25 On Conflict: 25 0n Conflict: E|
o
|| Matches: 515 | Modified: 3 | Added: 0 Deleted: 0 AI

Performing an online backup of a database
To perform an online backup of a database, follow the steps below:
1. Select Database » Backup

from the main menu.

Backup database £3

Save to: ||

0%

Start Close

2. Enter the filename for the backup database.

3. Click the Start button to start the backup process.
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savetol (C:\Data\sqlite\dbdemos2.db3
1%

The backup process can be canceled by clicking the Cancel button.

If the source database is encrypted, the backup database will be encrypted using the same
encryption key.

Note: the backup is performed using the SQLite Online Backup API. According to SQLite
documentation:

"The online backup API allows the contents of one database to be copied into another database,
overwriting the original contents of the target database. The copy operation may be done
incrementally, in which case the source database does not need to be locked for the duration of the
copy, only for the brief periods of time when it is actually being read from. This allows other
database users to continue uninterrupted while a backup of an online database is made."

Editing tables

» Creating a table

» Editing a table

» Renaming a table

» Deleting a table

» Editing fields

» Editing indexes

» Editing foreign keys

» Editing constraints

» Editing table triggers


http://www.sqlite.org/backup.html
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» Copying fields, indexes, constraints and triggers using the clipboard

» Applying the changes after editing a table
» Limitations
Creating a table
To create a table in the selected database, follow the steps below:
1. Select
Object » New Table

from the main menu, or New Table from the left tree panel popup menu. This enters the table
editing mode:

4 SQLite Expert Professional 5.0 (x86) o [BOE

File View Database Import/Export Object SOL Transaction Scripting Tools Help
D (3 {5 B |~ . 3 000 5 5 iE S0 A A ©E O oficao0Bie [~

Database: dbdemos Table: animals File: C\Data\sglite\dbdemos.db3 5QLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FTS5 RTREE]

v D dbdemos J Database | Extensions | Schema | Data | DDL | Design ‘ SQL builder | SQL | Scripting |

ﬁ animals

E biolife J General | Columns | Primary Key | Indexes | Triggers | Foreign Keys | Unique Constraints | Check Constraints | Change Script
E clients Table Mame || |

E country

ﬁ custoly Temporary

E ST Without RowlD
E employee
E events
ﬁ heldings
E industry
E items

E master
E nextcust
ﬁ nextitem
E nextord
ﬁ orders
E parts

E reservat
E vendors
ﬁ venues
E Wapia

Me declared columns,

Apply Cancel

Modified - dick apply to save changes.

2. If you want to create a temporary table, check the "Temporary' checkbox.
3. If you want to create a table without rowid, check the 'Without RowID' checkbox.

4. Enter a name for the table.

5. Add, modify or delete columns.

6. Add. modify or delete primary key.
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7. Add, modify or delete indexes.

8. Add. modify or delete foreign keys.

9. Add. modify or delete constraints.

10. Add, modify or delete triggers.

11. Apply the changes.

Editing a table

To edit an existing table, follow the next steps:
1. Select the table in the left tree panel.

2. Go to the Design tab.

#, SOLite Expert Professional 5.0 (x36) = B 53
File View Database Import/Export Object SOL Transaction Scripting Tools Help
GGaLGE=Ey2GRERHREGLG BT B0y Q00 HEEEE SO0 A A @G @ ofica0108ue 5
Database: dbdemos Table: orders File: C:\Data\sqlite\dbdemos.db3 5QLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FTS5 RTREE]
v~ dbdemos J Database | Extensions | Schema | Data | DDL | Design ‘ SOL builder | sqL | Scripting |
—E animals
_E (i J General | Columns | Primary Key | Indexes | Triggers | Foreign Keys | Unique Ci Check G Change Script \—
_E clients Recho |Co|umr1 Name |9QL Type |Size |Preci5\on |PK |Defau|t\c’a|ua ‘Not Null |Not Null Constraint Nam: & Add
— [ country > 1] OrderNa INTEGER |~ E I
— ] custoly | 2 CustNo INTEGER [ [ h=3E
*E customer | 3 SaleDate DATETIME [ [ Delete
—E employee | 4 ShipDate DATETIME
[ events : 5 EmpNo INTEGER = Modify
| P holdings | & ShipToContact CHAR 0 i i Move Up
P industry | | 7 ShipToAddr] CHAR 30 [ [
_E e B 8 ShipToAddr2 CHAR 30 [ [ Mave Down
_E =T | 9 ShipToCity CHAR 15 1 —
_E nedeust | 10/ ShipToState CHAR 20
L P nextitem | | 11 ShipToZip CHAR 10 [ [ Pacte
12 ShipTeCountry CHAR 20 [ [
| 13 ShipToPhone CHAR 15
| 14 ShipVIA CHAR 7
= par= | 15 PO CHAR 15
T reservat i 16 Tems CHAR 6
~[E] vendors | 17 PaymentMethod  CHAR 7
[ venues | 18 ltemsTotal CURRENCY
— [ vapw | 19 TauRate FLOAT
N 20 Freinht CLIRRFNCY ¥ ¥ F
4] 1l 3
Apply Cancel
Ready | | |

3. Add. modify or delete columns.

4. Add, modify or delete primary key.

5. Add. modify or delete indexes.

6. Add. modify or delete foreign keys.
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7. Add. modify or delete constraints.

8. Add, modify or delete triggers.

9. Apply the changes.

Renaming a table

To rename a table, follow the next steps:

1. Select the table you wish to rename in the left tree panel.

2. Select Table » Rename Table from the main menu.

¥ Rename Table orders = =

Mew name: ||:-rders.2|

QK Cancel

3. Enter the new name for the table in the table rename popup dialog.

4. Click OK.

Deleting a table or a group of tables

To delete one or more tables in the selected database, select the tables using the mouse or the
keyboard using CTRL or SHIFT operations, then press DELETE or select Delete from the left

tree panel popup menu, then click OK to confirm.

Editing columns

To edit the columns of a table, go to the Design tab on the outer tab view, and then go to the

Columns tab on the inner tab view:
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v dbdemos
—@ animals
_@ biolife Columns
_@ clients Column Mame SQL Type
[ country QrderNo INTEGER |~
[ custoly CustNo INTEGER
[ customer SaleDate DATETIME
[ employee ShipDate DATETIME
[ events EmpNo INTEGER
[ holdings ShipToContact CHAR
[ industry ShipToAddrl CHAR
LB items ShipToAddr2 CHAR
L] master ShipTaCity CHAR
L nextcust ShipToState CHAR
L nestitem ShipTeZip CHAR
_@ —— ShEanCnuntly CHAR
_@ p—— Sh!anPhnne CHAR
ShipVIA CHAR
—[E parts

PO CHAR.
—ﬁ reservat

Terms CHAR
] vendors PaymentMethod  CHAR

Bl

OooDoooEoDoDoDDoDDoDE S Es

Default Value Mot Mull |Mot Null C

i o

W e @ o pa [

[ venuss ItemsTotal CURREMCY
— [0 wap TaxRate FLOAT

oOooDoooooDoDooDoEooEE

Freinht CLRRFNCY

To add a column:

1. Click the Add button. This will pop up the column properties dialog.
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Column Mame

SOL Type >
Size

Precision

Default Constraint Mame

Default Value

Mot Mull Constraint Mame

Mot Mull

Mot Mull Conflict Clause ~
Unigque Censtraint Mame

Unique

Unigue Conflict Clause ~
Collate Constraint Mame

Collate b

Cancel

2. Enter the desired properties for the column: name, type, size, precision, default value, not null,
unique and collation.

3. Click OK to close the dialog.

To delete a column:

1. Select the column in the list.

2. Click the Delete button.

3. Click OK to confirm.

To modify a column:

1. Select the column in the list.

2. Click the Modify button. This will pop up the column properties dialog.

3. Change the desired properties for the column: name, type, size, precision, default value, primary
key, collation, not null, unique, collate, check constraints and foreign key references.

4. Click OK to close the dialog.
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To change the order of the columns in a table:
Use the Move Up and Move Down buttons.
To create an Autoincrement column:

SQLite allows the creation of a single auto-increment column for a table, and only if the field is
declared as INTEGER PRIMARY KEY.

To create an auto-increment column, go to the Primary Key tab and declare a primary key on a
single INTEGER column, then select the Autoincrement option:

# 4 Primary Key Celumn Editor = =2
Colurmn Mame [ 8[G ] ‘
Expression
Collate | >
Sort Crder | b

Autoincrement

QK Cancel

Editing indexes

To edit the indexes of a table, go to the Design tab on the outer tab view, and then go to the Indexes
tab on the inner tab view:
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—@ animals
—[ bialife
_ﬁ clients Recho Index Name Columns  |Unique | WHERE Clause
7@ country I 1]idx_orders_CustMo  Custho ]
—@ custoly
—@ customer
[ employee
*@ events
[ holdings
[ industry
—@ items
—ﬁ rnaster
— nextcust
—@ nextitem
—@ nextord
—[] orders
—[E parts
—ﬁ reservat
—@ vendors
] venues
—@ Wapia

To add an index:

1. Click the Add button. This will pop up the index properties dialog:
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¥ Index Editor = B E32

Index Mame "

Unigue

WHERE Clause

. | |Rean:| Column Mame |Sort Order |Collate Expression Add

Insert
Delete
Madify

Columns <Mo data to display> Move Up

Mowve Down
Copy
Paste
] I k
0K Cancel

2. Enter the desired properties for the index: name, unique, WHERE clause and columns.
3. To add a column to the index, click the Add button.

4. To remove a column from an index, select it in the list and click the Delete button.

5. To change the order of the fields in an index, use the Move Up and Move Down buttons.
6. Click OK to close the dialog.

To delete an index:

1. Select the index in the list.

2. Click the Delete button.

3. Click OK to confirm.

To modify an index:

1. Select the index in the list.

2. Click the Modify button. This will pop up the index properties dialog.

3. Change the desired properties for the index: name, unique, WHERE clause and columns.
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4. To add a column to the index, select it in the left and click the Add button.

5. To remove a column from an index, select it in the list and click the Delete button.

6. To change the order of the fields in an index, use the Move Up and Move Down buttons.

7. Click OK to close the dialog.

You need to add at least one column to a table before adding any indexes.

Indexes associated with unique constraints cannot be deleted or modified. They are created
automatically by the SQLite engine and their name follows this pattern:

'sqlite _autoindex <tablename> <n>'where <tablename> is the name of the table, and <n>is a
number starting from 2. To delete or modify an index associated with a unique constraint, delete or

modify its associated constraint.

Note: You can find more information about some issues with primary keys in SQLite here.
Editing primary keys
To create a primary key constraint, open the table editor and go to the Primary key tab:

44 SOLite Expert Professional 5.0 (x86) o [EOE

File View Database Import/Export Object SOL Transaction Scripting Tools Help

P

» Lz =0 Lp in @l @™ ] 0w by gl @ 2 ) 5] g3 A &7 @ [2 O office2010Blue T
Database: dbdemos Table: orders File: C:\Data\sqlite\dbdemos.db3 5QLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FTS5 RTREE]
0 "idemm Database | Extensions | Schema | Data | DDL | Design | SQOL builder | SOL | Scripting

- animals
'j (i General | Columns | Primary Key | Indexes | Triggers | Foreign Keys | Unique Constraints | Check Constraints | Change Script
'j clients

=
o country
'j custaly Constraint Name

Primary Key

=
|| custorner On Conflict -
=

L employee

[T events

,ﬁ ) Primary Key Columns

- heldings
'j industry Rechlo Column Name |Sort Order |Collate Expression |Autoincrement Add

'j items k 1By T Z Z l:l

=
[ master

Insert

[ nextcust Delete
== ;

[ nextitemn
'j nextord
=

|- orders

=
£ parts
=

|- reservat

Modify

'j vendors Copy
'j venues

'j Wapia

Ready

You can modify the following properties for the table primary key: constraint name, conflict clause
and columns.

Note: you can only declare a single primary key for a table. If the primary key has a single column
then it will be created as a column constraint, otherwise it will be created as a table constraint.
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Editing foreign keys

SQLite added full support for foreign keys in version 3.6.19 of the library. SQLite Expert added
support for foreign keys in version 2.2.0.

To create a foreign key, go to the Design tab and then go to the Foreign Keys sub-tab:

% 50Lite Expert Professional 5.0 (x86) o [BOE

File View Database Import/Export Object SOL Transaction Scripting Tools Help
GRaGHEH=E - GRAFLL BT ORI P ww 000 BEEEHE B0 A A @ F @ oficoomw.  [-]
Database: dbdemos Table: orders File: C:\Data\sqlite\dbdemos.db3 5QLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FTS5 RTREE]
v~ dbdemos J Database | Extensions | Schema | Data | DDL | Design ‘ SQL builder | saL | Scripting |

—E animals
= | Trrres | Foreign Keys | i Zarsten | Tharh tovare | Change Script

[ biolife J General | Columns

_E clients Recho |Constraint Mame |Parer1t Table |Chi|d Key |Parent Key |On Delete |On Update |Match |Deferrabla |Ir1itia||y | Add
_E country b 1 customer | ~ CustMNo CustMNo | - | - = | =

_E custely E Insert
*E customer —
_E employee
_E events —
_E heldings —
—E industry
_E e Paste
_E master
_E nextcust
_E nextitem
_E nextord
_E orders
_E parts
—E reservat
_E vendors
—E wenues
*E Wapia

Primary Key

Apply Cancel

Ready | | |

To add a foreign key:

1. Click the Add button. This will pop up the table Foreign Key Editor:
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Constraint Name | |
Child Key | &
ParentTable | Fl
Parent Key | =]
On Delete | Fl
On Update | Fl
Match | |
Deferrable | &
Initially | Fl

==n

2. Enter the desired properties for the foreign key: constraint name, parent table, child key, parent
key, and ON DELETE, ON UPDATE, MATCH, DEFERRABLE and INITIALLY clauses.

3. To select the child or parent keys, click on the corresponding '..."' button. This pops up the
column selection dialog:

Ayailable columns Selected columns:
CustMo | Add-> |

SaleDate

ShipDate | Add All->

EmpMe

ShipToContact
ShipTodddr
ShipToAddr2
ShipTeCity
ShipTobState
ShipTedip
ShipToCountry
ShipToPhone

. EEEN
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4. Select the desired columns, then click OK to close the column selection dialog.
5. Click OK to close the foreign key dialog.

To delete a foreign key:

1. Select the foreign key in the list.

2. Click the Delete button.

3. Click OK to confirm.

To modify a foreign key:

1. Select the foreign key in the list.

2. Click the Modify button. This will pop up the foreign key properties dialog.

3. Change the desired properties for the foreign key: name, parent table, child key, parent key, and
ON DELETE, ON UPDATE, MATCH, DEFERRABLE and INITIALLY clauses.

4. Click OK to close the dialog.

Limitations:

It is not possible to restructure a table that is referenced by one or more foreign keys. When
restructuring a table, SQLite Expert renames the table, creates a new table with the original name,

copies the data from the temporary table, then deletes the temporary table. A foreign key
referencing a table prevents it from being restructured.

Notes:

The foreign keys are enabled by default in SQLite Expert when opening a database.

If the foreign key has a single column then it will be created as a column constraint, otherwise it
will be created as a table constraint.

Editing constraints

To edit column constraints, see Editing columns.

Unique Constraints

To edit the unique constraints of a table, go to the Design tab on the outer tab view, and then go to
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the Unique Constraints tab on the inner tab view:

) [8 (1) Office2010Blue [+]

—@ animals
[ biolife
—ﬁ clients
*@ country
—@ custoly
—@ customer
[ employee
*@ events
[ holdings
[ industry
—@ items
—ﬁ rnaster
[ nextcust
—@ nextitem
—@ nextord
[T orders
—[E parts
—ﬁ reservat
—@ vendors
] venues

—@ Wapia

Unique Constraints

To add a Unique constraint:

1. Click the Add in the Unique Constraints group box. This will pop up the unique constraint
properties dialog:
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¥ Unique Constraint Editor = B 2
Constraint Mame
| |F‘.ecN|:u Column Mame |Sort Order |Collate Expressicn Add
Insert
Delete
Columns Modify
<Mo data to display>
Move Up
Move Down
Copy
On Conflict -
Ok Cancel

2. Enter the desired properties for the unique constraint: name, columns (each with optional collate
and sort order) and conflict clause.

3. Click OK to close the dialog.

To delete a Unique constraint:
1. Select the unique constraint in the list.
2. Click the Delete button.

3. Click OK to confirm.

To modify a Unique constraint:
1. Select the constraint in the list.
2. Click the Modify button. This will pop up the unique constraint properties dialog.

3. Change the desired properties for the unique constraint: name, columns (each with optional
collate and sort order) and conflict clause.
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4. Click OK to close the dialog.

Note: You need to add at least one column to a table before adding any unique constraints.

Check Constraints

To edit the check constraints of a table, go to the Design tab on the outer tab view, and then go to
the Check Constraints tab on the inner tab view:

‘-’Ef_': 5QLite Expert Professional 5.0 (x86) = = &2

File View Database Import/Export Object SOL Transaction Scripting Tools Help
GRaIGH=-3RERFRE G I3 15 ww 00 BEEOODEA A OFQorceanine |-

Database: dbdemos Table: orders File: C:\Data\sqlite\dbdemos.db3 SOLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FT55 RTREE]

v~ dbdemos J Database | Extensions | Schema | Data | DDL | Design ‘ SOL builder | sQL | Scripting |

E animals

E biolife J General | Columns | Primary Key | Indexes | Triggers | Foreign Keys | Unique Constraints | Check Constraints | Change Script

ﬁ clients | |RE(NU |Cunstrair1t Mame |Expressiur1 | Add
E country
E custoly .
[ customer Delete
ﬁ employee
= rents Modify
E holdings Copy
E industry
E — Paste
E master
E nextcust
ﬁ nextitem
E nextord
ﬁ orders
E parts
ﬁ reservat
E vendors
E VEMUES
ﬁ Wapia

<Mo data to display>

Apply Cancel

Ready

To add a Check constraint:

1. Click the Add in the Check Constraints group box. This will pop up the check constraint
properties dialog:
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¥ Check Constraint Editor = B ER

Constraint Mame ||

Expression

QK Cancel

2. Enter the desired properties for the check constraint: name and expression.

3. Click OK to close the dialog.

To delete a Check constraint:
1. Select the constraint in the list.
2. Click the Delete button.

3. Click OK to confirm.

To modify a Check constraint:

1. Select the constraint in the list.

2. Click the Modify button. This will pop up the check constraint properties dialog.
3. Change the desired properties for the constraint: name and expression.

4. Click OK to close the dialog.

Note: You need to add at least one column to a table before adding any check constraints.

Editing table triggers

To edit the triggers on a table, go to the Design tab on the outer tab view, and then go to the
Triggers tab on the inner tab view:
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- country (r———
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To add a trigger:

1. Click the Add button. This will pop up the trigger dialog:

2. Use the trigger dialog to visually design the CREATE TRIGGER script.
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3. Click OK to close the dialog.

To delete a trigger:
1. Select the trigger in the list.
2. Click the Delete button.

3. Click OK to confirm.

To modify a trigger:

1. Select the trigger in the list.

2. Click the Modify button. This will pop up the trigger dialog:

3. Use the trigger dialog to visually design the CREATE TRIGGER script.

4. Click OK to close the dialog.

Copying fields, indexes, constraints and triggers using the clipboard

While editing tables, SQLite Expert allows copying columns, indexes, constraints and triggers
between tables using the clipboard.

To copy a column or a group of columns to clipboard, go to the Columns tab, select the desired
fields and then press the Copy button.

To paste one or more fields from the clipboard, go to the Columns tab and then press the Paste
button.

Indexes, constraints and triggers can be copied using the clipboard using a similar procedure.

Applying the changes after editing a table

After editing a table, you can apply all the changes by clicking on the Apply button, or you can
cancel the changes by clicking on the Cancel button.

If you choose to apply the changes, SQLite Expert will create a new table with the new structure,
copy all the existing data from the old table, and then delete the old table. If any columns have been
deleted from the table, the data in these columns will be lost.

Note: SQLite Expert will automatically start a nested transaction before attempting to apply
changes. If any errors occur, the transaction will be rolled back and you will be given the chance
to correct the error before another attempt to apply the changes.

Before applying the changes, you can see the generated script on the Change Script tab.
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), SQLite Expert Professional 5.0 (x86)
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File View Database Import/Export Object SOL Transaction Scripting Tools Help

(FRF N

O EEE A A @ E @ office0108lue [~

v O dbdemos
E animals
[T biolife
ﬁ clients
E country
E custoly
E customer
ﬁ employee
E events
E heldings
E industry
E items
E master
E nextcust
ﬁ nextitem
E nextord
ﬁ orders
E parts
ﬁ reservat
E vendors
E Venues
ﬁ Wapia

b L |l 8 & G L R
Database: dbdemos Table: orders File: C:\Data\sqlite\dbdemos.db3

SQLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FTS5 RTREE]

J Database | Extensions | Schema | Data | DDL | Design ‘ S0L builder | S0L | Scripting |

J General | Columns | Primary Key | Indexes | Triggers | Foreign Keys | Unique Constraints | Check Constraints | Change Script

1 IPRAGHA [main] .foreign keys = "off'; -
2

3 SAVEPOINT [sqglite_expert_apply_design transaction];

4

5 DROP INDEX [main].[idx orders CustMo];

[

7 ALTER TABLE [main].[orders] RENAME TO [sgliteexpert temp table 1];

8 =
9 CREATE TEMPORARY TABLE [orders] (

10 [OrderNo] INTEGER PRIMARY KEY,

11 [CustNo] INTEGER REFERENCES customer([CustNo]),

12 [SaleDate] DATETIME,

13 [ShipDate] DATETIME,

14 [EmpNo] INTEGER,

15 [ShipToContact] CHAR({Z0),

16 [ShipTolddrl] CHAR{30),

17 [ShipTolddr2] CHAR({30),

13 [ShipToCity] CHAR(15),

13 [ShipToState] CHAR{20),

20 [ShipToZip] CHAR (10},

21 [ShipToCountry] CHAR (20},

22 [ShipToPhone] CHAER{15),

23 [ShipVIZ] CHZR(7),

24 [PO] CHAR({15),

25 [Terms] CHAR(§),

26 [PaymentMethod] CHAR(7),

27 [ItemsTotal] CURBENCY, r

Apply Cancel

Madified - dick apply to save changes.

Limitations

If the current table is referenced in foreign keys, the following restructure operations are disabled:

O Delete or rename fields referenced in foreign keys

If the current table is referenced in foreign keys and a transaction is in progress, the following
restructure operations are disabled:

O Add, delete or modify fields

O Add, delete or modify constraints

O Add, delete or modify foreign keys

O Add, delete or modify primary keys

O Paste primary keys from clipboard
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Editing virtual tables

» Creating a virtual table

» Editing a virtual table

» Renaming a virtual table

» Deleting a virtual table

Creating a virtual table

To create a virtual table in the selected database, follow the steps below:
1. Select

Object » New Virtual Table

from the main menu, or New Virtual Table from the left tree panel popup menu. This enters the
virtual table editing mode:

qg 50Lite Expert Professional 5.0 (x86) o [BOE

File View Database Import/Export Object SOL Transaction Scripting Tools Help
2 (g ] B0 |+ (8 (9 3 000 S EEEHE G E A A @ @)0fice0108lue =

Database: dbdemos Table: orders File: C:\Data\sqlite\dbdemos.db3 5QLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FTS5 RTREE]

v D dbdemos J Database | Extensions | Schema | Data | DDL | Design ‘ SQL builder | SQL | Scripting |

ﬁ animals

E biolife General | Change Script
E clients Virtual Table Mame “ |
E country
ﬁ custoly
E customer '
E employee
E events
ﬁ heldings
E industry
E items

E master
E nextcust
[ nextitem Module Arguments
[ nextord
ﬁ orders
E parts
E reservat
E vendors
ﬁ wenues
E Wapia

Module Name ‘ =

Apply Cancel

Modified - dick apply to save changes.

2. In the virtual table editor, enter the name of the virtual table, the module name and the
arguments.
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%\ﬁnual Tables

3. Click Apply. The virtual table is created and the creation SQL can be inspected on the DDL tab:
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—[ bialife
—ﬁ clients
*@ country
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—@ customer
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—ﬁ mail_content
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—@ rmaster
—F nextcust
—ﬂ nextitem
—ﬁ nextord
—@ orders
[ pants

—@ reservat
—ﬁ vendors
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[ wop
L mait

Editing a virtual table
To edit an existing virtual table, follow the steps below:
1. Select the virtual table in the left tree panel.

2. Go to the Design tab.
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File View Database Import/Export Object SOL Transaction Scripting Tools Help

GGaGHm - 1CEREHRFPLBGE BT 5yww 000 H5ERHid &0 0 A A O LE @ office20108ue >
Database: dbdemos  Virtual Table: mail File: C:\Data\sqlite\dbdemos.db3 SOLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FT55 RTREE]
bt D dbdemos J Database | Extensions | Schema | Data | DDL | Design | S0L builder | 5aL | Scripting |

x ﬁ Tables

v Virtual Tables General | Change Script

Virtual Table Mame | mail

Module Name FT53 -

1 subject VARCHAR (25&) NOT NULL
Z body TEXT CHECK (length (body) < 10240)

Module Arguments

Apply Cancel

Ready

3. Perform the desired changes, then click Apply. The new table is created. If the old table
contains any records then the data is copied from the old table to the new table in which case you
will be prompted to review the column mapping for the data copy operation:

Please review the column mapping for recreating virtual table:
Source Field Destination Field -
SR subject
body body
Auto Clear All (04 Cancel

4. Click OK to copy the data from the old table to the new table.
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Renaming a virtual table

Renaming a virtual table is similar to renaming a table ot a view:

1. Select the virtual table you wish to rename in the left tree panel.

2. Select Object » Rename Table from the main menu.

3. Enter the new name for the virtual table in the table rename popup dialog.

4. Click OK.
Deleting a virtual table
To delete one or more virtual tables in the selected database, select the tables using the mouse or

the keyboard using CTRL or SHIFT operations, then press DELETE or select Delete from the left
tree panel popup menu, then click OK to confirm.

Editing views

» Creating a view

» Editing a view

» Deleting a view

Creating a view

To create a view, follow the next steps:
1. Select

Object » New View

from the main menu, or New View from the left tree panel popup menu. This enters the view
editing mode:
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-'Ef.'= 5QLite Expert Professional 5.0 (x86) = = &2

File View Database Import/Export Object SOL Transaction Scripting Tools Help
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Database: dbdemos  Virtual Table: mail File: C:\Data\sqlite'dbdemos.db3 SOLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FT55 RTREE]
v D dbdemos J Database

ﬁ animals

[ biolife General | Triggers | Change Script

Extensions | Schema | Data | DDL | Design ‘ S0L builder | S0L | Scripting |

ﬁ clients Miew Name |
E country

E sy Temporary
E customer :
ﬁ employee

E events

E heldings

E industry

E items

E mail_content
E mail_segdir
ﬁ mail_segments
E master

] nexteust

E nextitem

ﬁ nextord

E orders

E parts

E reservat

ﬁ vendors

E venues

E Wapio

E mail Apply Cancel

View Body

Madified - dick apply to save changes.

2. Enter a name for the view, and the SQL text for the view body (the AS clause).
3. If you want to create a temporary view, check the "Temporary view' checkbox.
4. Click the Apply button.

Note: there is a known issue in SQLite regarding invalid field names in views with no field
aliases. You can find more information about this subject here.

Editing a view

To edit an existing view, select it in the left tree panel and go to the Design tab. Here you can
change the name of the view and the SQL text of the AS clause.

Editing view triggers

To add, delete or modify triggers for a view, go to the Triggers tab on the inner tab view.
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-
L animals

Database | Extensions | Schema | Data | DDL | Design  SOL builder | SOL | Scripting

'j biolife General | Triggers | Change Script
L] clients RechMo Trigger Name | Temporary |Columns | Trigger Body |When Database Event | Trigger Action | WHEN Expression Add
'j country
it Insert
EEH custoly
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]

=
- employee

=

EH events

'j heldings
industry
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mail_content
mail_segdir
mail_segments
master
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=
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=
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= 0.

Fo] Wepio

'j mail Apply Cancel

Madified - dick apply to save changes.

To add a trigger, click the Add button. This command pops up the trigger editing window where
you can enter the name and all the parameters for the trigger. When you are finished with the
changes, click the OK button. To cancel the changes, click the Cancel button.

To delete a trigger, select it in the list and click the Delete button.
To modify a trigger, select it in the list and click the Modify button. This command pops up the
trigger editing window where you can enter the name and all the parameters for the trigger. When

you are finished with the changes, click the OK button. To cancel the changes, click the Cancel
button.

Applying changes

When you are done with the changes, click the Apply button. This command will delete the old
view and create a new one with the selected structure.

To cancel view editing before applying changes, click the Cancel button.
Note: SQLite Expert will automatically start a nested transaction before attempting to apply

changes. If any errors occur, the transaction will be rolled back and you will be given the chance
to correct the error before another attempt to apply the changes.

Deleting a view or a group of views

To delete one or more views in the selected database, select the views using the mouse or the
keyboard using CTRL or SHIFT operations, then press DELETE or select Delete from the left
tree panel popup menu, then click OK to confirm.
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Using SQL scripts

» Executing SQL scripts

» Saving and loading SQL scripts

» Creating a View from an SQL script

» Using parameters in SQL scripts

Executing SQL scripts

To execute an SQL script in the selected database, go to the SQL tab, type the SQL in the upper edit
window and press F5 or select

SQL » Execute

If the SQL script is a SELECT statement the result set will be displayed in the grid or as text,
depending on the current settings.

JJ.': 5QLite Expert Professional 5.0 (x86)

File View Database Import/Export Object SOL Transaction Scripting Tools Help
GGaLGHm - 1CEREHRFPLGY BT BFyww 000 H5EBHid &S00 A A O LE @ office0108ue >
SQLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FTS5 RTREE]

Database: dbdemos  File: C:\Data\sqlite\.dbdemos.db3

v~ dbdemos J Database | Extensions | Schema | Data | DDL | Design | SOL builder | saL | Seripting |
¥ ﬁ Tables
- S0L: *<Untitled>
¥ ﬁ Virtual Tables
73 mail 1 select * from animals
% Views
Mo 4 o+ — s v ox oA x| |E Stop Query *< Untitled>
NAME [size WEIGHT  [AREA E -
? Click here to define a filter
|
¥ |Angel Fish |--- 2 2 Computer Aquariums | &3 |
Boa 10 & South America m
Critters 30 20 Screen Savers ﬁ 3
House Cat 10 5 New Orleans m
Ocelot a0 35 Africa and Asia 7]
Parrot 5 5 South America o
Tetras 2 2 Fish Bowls Fod
«<Filter is Empty> Customize... 2

Query executed in 32 ms 0 rows affected, 0 total i

If the SQL script contains multiple statements separated by semicolon, they will all be executed.
However, only the results for the last statement (if it is a SELECT statement) will be displayed.

You can also execute only a part of the SQL script by selecting the text to execute and pressing F5.
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Cancelling the execution of a long-running SQL script
To cancel the execution of an SQL script, press ESC or select
SQL » Stop Query

You can also cancel the execution of a script by clicking the Stop Query button (only visible when
data is displayed in a grid).

Saving and loading SQL scripts

Saving an SQL script to a file
To save an SQL script to a file, select
SQL » Save SQL Script

from the main menu, or Save SQL Script from the SQL window popup menu. You will be
prompted to select a name for the script file.

Loading an SQL script from a file
To load an SQL script from a file, select
SQL » Open SQL Script

from the main menu, or Open SQL Script from the SQL window popup menu. A file dialog will
allow you to choose the script file which will be loaded in the SQL window.

You can also drop script files (with .sql extension) from the Windows environment in the SQL
window.

To load a recent SQL script from a file, select
SQL » Open Recent SQL Script

from the main menu, or Open Recent SQL Script from the SQL window popup menu. A sub-menu
will allow you to choose from the most recent 10 SQL script files.

Creating a View from an SQL script

After executing an SQL script that returns a cursor (a SELECT query), you can create a view from
this script by following the next steps:

1. Copy the whole script to the clipboard using CTRL+A and CTRL+C.
2. Create a new view by selecting

Object » New View



from the main menu, or New View from the left tree panel popup menu.

3. Paste the script into the View Body edit box.

4. Enter a name for the view.

5. If you want to create a temporary view, check the "Temporary view' checkbox.

6. Click the Apply button.

Using parameters in SQL scripts

In the SQL statements accepted by SQLite Expert, literals may be replaced by a parameter in one
of these forms:

?

INNN
:AAAA
@AAAA
SAAAA

The syntax is as described in the SQLite documentation, with one limitation: SQLite Expert
currently does not support "::" occurrences or suffixes enclosed in "(...)" in the SAAAA format.

When a parameter is encountered in an SQL statement, SQLite Expert will prompt for the value of
the parameter unless it was already defined. For example, in the included DBDEMOS database,
executing the following statement:

select * from biolife where [Species No] = @SpeciesNo;

will prompt for the value of @SpeciesNo:

Please enter the value for @Spedesio;

0K Cancel

Another way to use parameters is to enter them in the script, on the SQL tab. Most of the time,
SQLite Expert just reads lines of input from the SQL tab and passes them on to the SQLite library
for execution. But if an input line begins with a dot ("."), then that line is intercepted and
interpreted by the SQLite Expert program itself. Currently the "dot commands" are only used for
setting the values of parameters used in the queries, but more commands may be added in the
future.

The following "dot commands" are used with parameters:

SET PARAM param_name = literal value

This command sets the value of a parameter to the specified literal value. The literal value can be
a string, an integer number, a floating point number, a BLOB literal, or the value NULL. BLOB

literals are string literals containing hexadecimal data and preceded by a single "x" or "X"
character.


http://www.sqlite.org/lang_expr.html#varparam
http://www.sqlite.org/lang_expr.html#varparam

.RESET PARAMS
This command clears the values of all the parameters.

Note: all parameters are cleared after the execution of the last statement in the list.

Example 1:
The following script will not prompt for the value of the @SpeciesNo parameter:

.set param @SpeciesNo = 90020;
select * from biolife where [Species No] = @SpeciesNo;

Example 2:
The following script will prompt for the value of the @SpeciesNo parameter:
.set param @SpeciesNo = 90020;

.reset params;
select * from biolife where [Species No] = @SpeciesNo;

Note: the support for parameters in SQL statements using dot commands is experimental and its

syntax may change without notice.

Code Completion

Code Completion

Code Completion (Ctrl+Space) is a feature available in the SQL Editor. Code Completion
displays a resizable "hint" window that lists valid elements that you can select to add to your

code.



¥, SOLite Expert Professional 5.0 (x86)

= B 2R
File View Database Import/Export Object 50L Transaction Scripting Tools Help
xmhid=E~GhahIBEE @& = 9 O & S0 E A A @ L2 @) office2010Blue -
Database: dbdemos  File: C\Data\sqlite\dbdemos.db3 SQLite library: sqlite3.dll 3.19.3 [FTS3 FTS4 FTS5 RTREE]
v U dbdemos Database | Extensions | Schema | Data | DDL | Design | SOL builder | SCL | Scripting
b ﬁ Tables
. S0L: < Untitled=
¥ @ Virtual Tables
[ mail 1 select a.| from animals a
& Views
fisld BMP
field HAME
fisld STZE
field WEIGHT
field *
[ I *<Untitled=
NAME SIZE -
¥ Ik ETE 0 def e 3 Titer
+ |Angel Fish |-~ 2 2 Computer Aquariums | |?:
Boa 10 8 South America m
Critters 30 20 Screen Savers %
House Cat 10 5 Mew Orleans m
Ocelot 40 35 Africa and Asia i)
Parrot 5 5 South America
Tetras 2 2 Fish Bowls
=Filter is Empty> Customize... L
Query executed in 32 ms 0 rows affected, O total

Automatic code completion is on by default, and options for enabling and disabling Code
Completion are located on the Tools > Options > Code Completion dialog box.

( When Auto Invoke is enabled for Code Completion, typing a dot (.) invokes Code
Completion for the SQL editor. The Delay sets the duration of the pause before a Code
Completion window displays. Select a value between 0 and 10000.

(' However, you can use Ctrl+Space to invoke Code Completion even if the Auto Invoke

option is disabled.

Code Template Completion

Automatically adds a code template when you type a token that starts a template and press ctr1+J.

The default value is On (checked). For example: type ssf in the SQL window, then press
ctrl+J. The code is replaced by the "select * from..." template:

SELECT * FROM

The following predefined templates are available:
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atr = ALTER TABLE RENAME
ata = ALTER TABLE ADD COLUMN
an = ANALYZE

ad = ATTACH DATABASE

bt = BEGIN TRANSACTION

ct = COMMIT TRANSACTION

ci = CREATE INDEX

cui

CREATE UNIQUE INDEX

ct = CREATE TABLE

cta = CREATE TABLE AS

ctt = CREATE TEMPORARY TABLE

ctta = CREATE TEMPORARY TABLE AS

ctbd = CREATE TRIGGER BEFORE DELETE
ctbi = CREATE TRIGGER BEFORE INSERT
ctbu = CREATE TRIGGER BEFORE UPDATE OF

ctad = CREATE TRIGGER AFTER DELETE

ctai = CREATE TRIGGER AFTER INSERT

ctau = CREATE TRIGGER AFTER UPDATE OF

ctid = CREATE TRIGGER INSTEAD OF DELETE
ctii = CREATE TRIGGER INSTEAD OF INSERT
ctiu = CREATE TRIGGER INSTEAD OF UPDATE OF

fer = FOR EACH ROW

cv = CREATE VIEW AS
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cvt = CREATE VIRTUAL TABLE

rt

ROLLBACK TRANSACTION

df

DELETE FROM

dd = DETACH DATABASE

dt = DROP TABLE

di

DROP INDEX

dtr = DROP TRIGGER

dv

DROP VIEW

et

END TRANSACTION

ex = EXPLAIN

i = INSERT
ir = INSERT OR REPLACE
ie = IF EXISTS

ine = IF NOT EXISTS

Pg PRAGMA
re = REINDEX

rs = RELEASE SAVEPOINT

rts = ROLLBACK TO SAVEPOINT
scf = SELECT COUNT FROM

ssf = SELECT * FROM

sv = SAVEPOINT

ut = UPDATE TABLE

vc = VACUUM
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Viewing and editing data

» Viewing table data

» Editing table data

» Editing live queries

» Copying data between tables using the clipboard

Viewing table data

To view the data in the selected table, go to the Data tab. The data will be reloaded automatically
when you select a table. You can select the columns to be displayed using the 'Select columns'
dialog available from the grid popup menu.

The data is displayed in a grid or as text, depending on your Options.

4, SOLite Expert Professional 5.0 (x36) = B =
File View Database Import/Export Object SOL Transaction Scripting Tools Help
GGaGHm - 1CEHRFPLGY BT 5yww 000 H5ERHid &0 A A ©LE @ office20108ue >
Database: dbdemos(1) Table: events File: C:\ProgramData\50Lite Expert\Professional 5 - 32bit\Data\dbdemos.db3 SOLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FT55 RTREE]
= Views 3 J Database | Extensions | Schema | Data | DDL | Design | SOL builder | saL | Seripting |
E.J_%d:_:nb‘iin | M M P MWt = A v X oA &k | Refresh
—E animals rowid |Ever1tNo |VenueNo |Ever1t_NarnE |E\.rer1t_Date |E\.rer1t_T\me |Event_DE;criptior1 -
*E biclife i Click here to define a filter
_E clients 3 1 1 5 Men's Track and Field | 19‘]6-06-15| ~ | 10:00:00.000 | ~ Outdoor arena, one of the most poj
—E country | 2 2 3 500 meter Men's Speed Skating 1996-06-16 08:00:00.000 World record for 500 meter speedsk
—E custoly | 3 3 5 100 Meter Individual Medley 1996-06-21 14:00:00.000 Consult refund policy for cancellatis
*E customer | 4 4 2 Women's Basketball Finals 1996-06-21 20:00:00.000 Held indoors at Harmon Arena. Las =
| 5 5 7 Women's Cycling 20mi 1996-06-19 09:00:00.000 Consult map of venue (City Route).
| & ] 1 Men's Gymnastics Finals 19%6-06-20 109:00:00.000 All comps suspended for this event,
-5 hold\r;;s : 7 7 1 Women's Hockey Finals 1996-06-20  11:00:00.000  Limited seating due to arena reconf
_E industry | g 8 3 Women's High Dive Finals 1996-06-19 22:00:00.000 World premiere event. All comps al
_E e 3 || 9 9 1 Karate Finals 1996-06-21 16:00:00.000 Possible venue change due to weatl
_E master B 10 10 8 Kayak Level IV Finals 1996-06-20 16:00:00.000 River access is restricted. Advise sp
_E S | i 1L 5 Lacrosse Semi-finals 1996-06-17 14:00:00.000 Introduced this year to the agenda,
_E — | 12 12 5 Polo Finals 19%6-06-22 13:00:00.000 Limited seating due to reconfigurat
_E nestord | 13 13 3 Women's Soccer Finals 1996-06-23 14:00:00.000 (null)
14 14 9 Surfing: Freestyle Finals 1996-06-23 08:00:00.000 Limited access: advise spectators o
T orcers | 15 15 10 Swimming: 100 m Finals 1006-06-22  12:00:00.000 | (null)
T parts S 16 16 5 Track & Ficld: Women's Finals ~ 1996-06-22  12:00:00.000  (null)
0 resenvat | 17 17 4 Archery Finals 1996-06-01  17:00:00.000  Attendance limited. Contact VIP of
] vendors | 18 18 (null) Men's Hockey Finals 1998-12-02  20:00:00.000  The battle for the gold.
] venues | 19 19 (null) Men's Downhill Giant Solom 1998-01-15 12:00:00.000 Men's Downhill Giant Solomn always
75 Wapia [ | 20 20 (il hen's Ski lumnn Finals 1048-01-15 10-00-00 000 [aull
— Virtual Tables <Filter is Empty> B
5 views L[] i »
-
Ready | | | |

63 /124



SQLite Expert 5.5

%SQLi‘te Expert Professional 5.0 (x86) = = &2
File View Database Import/Export Object SOL Transaction Scripting Tools Help
GGaGHm - 1CEHRFPLGY BT 5yww 000 H5ERHid &0 A A ©LE @ office20108ue >
Database: dbdemos(1) Table: events File: C:\ProgramData\50Lite Expert\Professional 5 - 32bit\Data\dbdemos.db3 SOLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FT55 RTREE]
L - - N _ -
55 Views “| | Database | Extensions | Schema | Data | DDL | Design | SOL builder | saL | Scripting |
D godemasily rowid EventNo VenueNo Event Name Event_Date Event Time  Event Description
'—ﬁ Tables | |||——
| animals 1 1 5 Men's Track and Field 1996-06-15 10:00:00.000 Outdoor arena, one of the most pof
- = = 3 500 meter Men's Speed Skating 1996-06-16 08:00:00.000 World record for 500 meter speeds
75 biclife 3 3 5 100 Meter Individual Medley 1996-06-21 14:00:00.000 Consult refund policy for cancells
—E clients 4 4 Z Women's Basketball Finals 1596-06-21 Z0:00:00.000 Held indoors at Harmon Arena. Las
_E + H H 7 Women's Cycling 20mi 1996-06-19 09:00:00.000 Consult map of wenue (City Route)
country 6 6 1 Men's Gymnastics Finals 1996-06-20 09:00:00.000 All comps suspended for this event
—E custoly 7 7 1 Women's Hockey Finals 1996-06-20 11:00:00.000 Limited seating due to arena recor
,E ST 8 8 3 Women's High Dive Finals 1996-06-19 22:00:00.000 World premiere ewvent. Rl1l comps &
3 3 1 Karate Finals 1996-06-21 16:00:00.000 Possible venue change due to weath
10 10 2 Kayak Level IV Finals 1996-06-20 16:00:00.000 Riwer access is restricted. BAdwvis
11 11 5 Lacrosse Semi-finals 1996-06-17 14:00:00.000 Introduced this wvear to the agenda
_E hold 12 12 5 Polo Finals 15996-06-22 13:00:00.000 Limited seating due to reconfigurs
oldings 13 13 3 Women's Soccer Finals 1996-06-23 14:00:00.000 {null)
—E industry 14 14 9 Surfing: Freestyle Finals 1996-06-23 08:00:00.000 Limited access: advise spectators
_E items : 15 15 10 Swimming: 100 m Finals 1996-06-23 12:00:00.000 (null)
B 16 18 5 Track & Field: Women's Finals 1996-06-22 12:00:00.000 {null})
_E master 17 17 4 Archery Finals 1996-06-01 17:00:00.000 Attendance limited. Contact VIP
—E nextcust 18 12 ({null) Men's Hockey Finals 1998-12-02 20:00:00.000 The battle for the gold.
_E nextitern 19 19 ({null) Men"s Downhill Giant Solom 1998-01-15 12:00:00.000 Men's Downhill Giant Solom always
z0 20 (null) Men's Ski Jump Finals 1958-01-15 10:00:00.000 (null)
T nextord 21 21 (null) Women's Downhill Ski Finals 1998-01-26 14:00:00.000 {null)
L orders 22 22 (null) Men's Relay 1996-06-20 15:00:00.000 (null)
E 23 23 (null) Baseball Quarter-finals 1996-06-15 14:00:00.000 {null})
— parts =
—E reservat
—E vendors
—E VEnues
- T wopa
— @ Virtual Tables
—% Views | 4
= 4] [} 3
Ready | | |

Editing table data

If the data is displayed in a grid, you can edit the records in the grid or using the appropriate
editor. SQLite Expert provides three type of field editors:

( The Text Editor for memo fields (text fields such as CHAR, VARCHAR with no specified size)
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' Text Editor: Motes = B R
|AI5|:| known as the big spotted triggerfish. Inhabits outer reef areas and feeds upon Load
crustaceans and mellusks by crushing them with powerful teeth. They are voracious eaters,
and divers report seeing the clown triggerfish devour beds of pearl oysters. Save
Do not eat this fish. According to an 1878 account, "the poisonous flesh acts primarily upen Clear
the nervous tissue of the stomach, cccasioning viclent spasms of that organ, and shortly
afterwards all the muscles of the body, The frame becomes rocked with spasms, the tongue oK
thickened, the eye fixed, the breathing laborious, and the patient expires in a paroxysm of
extreme suffering.”

Cancel
Mot edible.
Range is Indo-Pacific and East Africa to Somoa.
¥ Word wrap

( The Image Editor and the Hex Editor for the other BLOB fields (GRAPHIC, BLOB)

#» Image Editor: Graphic (226%)

Save

Copy

Paste
Clear
Open

Open with...

Cancel
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%Hm{ Editor: Graphic o = 2R
IEEREED) o100 oool DEST 0000 424D DES7 0000 [i...EB ..BMB .. A Load
0x000E 0000 0000 3604 0000 2800 0000 FROOD  wewe@ow.{...d. B
0x001C 0000 9600 0000 0100 0800 0000 0000 we weweeowanen Save
0x002L 2393 0000 0000 0000 0000 0000 0001 7 weeeeenwanen
0x0038 0000 0000 0000 0000 0000 0000 BEOD  weueeweenwan - Copy

0x0046 OCBF 0000 QOBF BFOO BFOO 0000 BFOD  wieeeiiede--i-
0x0054 BF00 BFBF 0000 COCO CO00 CODC COOO i..RRR.ATA. Paste

[P0
0x0062 FOCL R600 CCFF FFOO 99FF FFOQ €6FF &E!.I9%. §9.£7
0x0070 FFOO 33FF FFOO FFCC FFOO COCC FFOO §.399.9Iv.11¢. Clear
0x007E 99CC FFOO €6CC FFOO 33CC FFOO 00CC igr.fii:'r.aigr..i -
0x008C FFOO FF99 FFOO CC99 FFOO 9999 FFOO §.% ¥.I 9. #.
0z009L 6699 FFOO 3399 FFOO 0099 FFOO FFé6é £ §.3 §.. ¥.¥f Cancel

0x00&8 FFOO0 CCéé FFOO 9966 FFOO 6666 FFOO %.If%. f¥.ff%.
0x00BE 3366 FFOO 0066 FFOO FF33 FFOO CC33 3£7..f7.937.13
0x00C4 FFOO0 9933 FFOO 6633 FFOO 3333 FFOO . 39.£37%.33%.
0x00D2 0033 FFOO CCoo FFOO 9900 FFOO 6600 .3%.I.%. .9%.f.
0x00EC0 FFOO 3300 FFo0 FFFF CCO0 CCFF CCO0 %.3.%.99I.I¢I.
0x00EE 99FF CCO0 66FF CCOO 33FF CCO0 00FF  §i.fgi.sgi..
0x00FC CCo0 FFCC CCOO0 CCCC Ccoo gsecc ccoo I.¢If.ifi. IT.
0x010& 66CC CCOO 33CC CCOO Q0OCC CCOO0 FFess £II.3I1..I1I1.%
0x0118 CCO0 CC9% CCO0 9999 CCOO 6699 ccoo I.I 1. I.f£ I.
0x0126 3399 CCOO 0099 CCo0 FFe6 CCO0 CCeé 3 I.. I.9f1.1f
0x0134 CCO0 9966 CCO0 6666 CCOO 3366 Ccoo I. £I.££1.3f£1.
0x0142 0066 CCOO FF33 CCOO CC33 CCoo 9933 .fI.¢3i.izi. 3

The appropriate editors are available by right-clicking on the field to be edited. Non-text BLOB
fields can be edited using either the Hex or Image editor.

Double-clicking on a record will bring up the record editor, if this option is enabled:
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Ballistoides conspicillum

Blodes onpicitom
L
sy

i
|

Editing live queries

The result set of a SELECT SQL query is editable if the query contains data from a single table.
Editing the result set of a query is similar to editing the data in a table, the only difference being
that the grid is displayed on the SQL tab.
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% SQLite Expert Professional 5.0 (x86) = = &2
File View Database Import/Export Object SOL Transaction Scripting Tools Help
GGaGHm - 1CEHFPLGY BT BFyww 000 HEBHEH &S00 A A O LE @ office20108ue >
Database: dbdemos(1) Table: biclife File: C:\ProgramData\SCOLite Expert\Professional 5 - 32bit\Data\dbdemes.db3 SOLite library: sqlite3.dll 3.19.3 [FTS3 FT54 FT55 RTREE]
— -
i Views 3 J Database | Extensions | Schema | Data | DDL | Design | SOL builder | saL | Scripting |
[ dbdemas(1)
S0L: "<Untitled>
'—ﬁ Tables
—E animals 1 select * from customed]
-] biclife
—E clients
—E country
—E custoly
*E customer
—E employee
Mo 4 B W+ = . v X A kR @ Execute 5QL Stop Query *«Untitled>
—E events =
1 holdings CustNo |Company |Addr [addrz ity [state |zip -
—E industry = Click here to define a filter =
E |
[ items —l [*] 1221) Kauai Dive Shoppe |-+ 4-976 Sugarloaf Hwy |-+ Suite 103 |- Kapas Kauai |-+ HI |-+ 24766-1234
— [ master L 1231 Unisco PO Box Z-547 (null) Freeport (null) (null)
_E nextcust |1 1351 Sight Diver 1 Meptune Lane (null) Kato Paphos (null) (null)
_E nextitem 1354 Cayman Divers World Unlimited PO Box 541 (null} Grand Cayman (null) (null)
_E nextord 1356 Tom Sawyer Diving Centre 632-1 Third Frydenhoj (null} Christiansted 5t. Croix 00820
—E orders |1 1380 Blue Jack Aqua Center 23-738 Paddington Lane Suite 310 Waipahu HI 99776
—E parts =| | L 1384 VIP Divers Club 32 Main 5t. (null} Christiansted 5t. Croix 02800
—E reservat | 1510 Ocean Paradise PO Box 8745 (null} Kailua-Kena HI 94756
—E vendors | 1513 Fantastique Agquatica 732 999 #12A-T7 AA. (null) Bogota (null) (null)
—E venues |1 1351 Marmot Divers Club 872 Queen St (null) Kitchener Ontaric G3N 2E1
,E Wapix 1560 The Depth Charae 15243 Undenwater Fuw. (nulll Marathon FL 35003
_ Virtual Tables <Filter is Empty> Customize... 2
I Views AR il N
-
Query executed in 65 ms | Record 1of 28 | 0rows affected, 0 total i

Copying data between tables using the clipboard

To copy data between tables using the clipboard, follow the next steps:

1. Select the source table and the Data tab.

2. Select the records in the source table using the mouse or the keyboard and press CTRL-C.
3. Select the destination table and go to the Data tab, then press CTRL-V.

4. The Field Mapping dialog pops up:

Please review the field mapping for the Paste operation:
Source Field Destination Field -
TR rowid
Mame Marme
Capital Capital
Continent Continent
Area Area
Population Population
Auto Clear All (04 Cancel
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5. Map the source fields to the destination fields, or press the Auto button to match the source
fields to destination fields by name.

6. Press the OK button.

7. SQLite Expert is using a transaction during the Paste operation. If any errors are encountered,
the transaction is rolled back.

Using the SQL Query Builder

The integrated SQL Query Builder is a visual query builder component that allows you to build
complex SQL queries via an intuitive visual query building interface.

To work with the Query Builder you need basic knowledge of SQL concepts. The Query Builder

will help you to write correct SQL code hiding technical details, but only understanding of the SQL
principles will make possible to achieve desired results.

» The Query Builder Layout

» Building SQL queries using the Query Builder

» Generating Views using the Query Builder

The Query Builder Layout

To access the Query Builder, go to the SQL Builder page. The Query Builder is divided into three
sections: the Table List, the Query Building Area and the Columns pane. For a better usage of the
available screen space, the generated SQL script is sent to the SQL page where it can be executed
like a script entered manually.
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File View Database Import/Export Object SOL Transaction Scripting Tools Help
BaE -G - BB BH8 2-0-0-0- 8-
Database: dbdemos Table: events File: E\Data\sqlite\dbdemos.db3 SOLite library: sqlite3.dll 3.13.0 [FTS3 FT54 FT55 RTREE]  Style:  Turquoise Gray -
w j dbdemos +|| Database BEdensions Schema Data DDL  Design SQLbuilder SOL  Scripting
v [l Tables -
: animals (7) Main .. main.animals
-1 bioli - main.biclife
B e iems (mar Q. i
= -d x -
B clients (5) . - Or E (main) . items (main) mmam‘dlenf
country (18 1 1 main.country
= custn\ryé[))) i # CustMo Integer ol *OrderNo Integer —= *OrderNo [nteger . main.custoly
|E (LIStDr'::er 5) #  Company Char CustNo Integer ¥ IltemNo Integer .. main.customer
|E | 2) = - # SaleDate Datetime #  PartNo Integer . main.employee
|E employee Addr2 Char % ShipDate Datetime %  mainevents
IE " City Char EmpMo Integer Discount Float  mainholdinas
E=E heldings (3€) State Char % ShipToContact Cha - L !
| industry (7) Zip Char % ---ma!n‘!ndustry
= -
[ items (943) Country Char ShipToAddr2 Char ---ma!n‘ltems
E mail_content (0) Phone Char ShipTaCity Char ---ma!nmawl_cont.ent
f mail_segdir (0] FAX Char ShipTaState Char ---ma!n‘mawl_segdlr
E mail_segments (0} TaxRate F_Icet - ShipToZip Char E ---ma!n‘mawl_segments
: raster (108) ot e T T ma!n‘master
|| nextcust (1) ---mafnﬂ:(t(t;ust
-] nestit 1 - main.nextitem
|E :m‘D:ﬂﬂ(}) b Output Expression Aggregate Alias Sort Type Sort Orde = . main.nextord
|E orders (203) = [main].[customer].[Custo] main.orders
lE arts (59) =] [main].[customer].[Company] .. main.parts
L; feservat (100} < [main].[customer].[Addr1] - main.reservat
|E vendors (23] . [main].[orders].[SaleDate] - mainvendors
lE venues (10) - [main].[orders].[ShipDate] - Main.venues
lE Wepua (28) e [main].[orders].[ShipToContact] .. main Wapa
ﬁ‘aﬁual?hbles = [main].[orders].[ShipToAddrl] - main.mail
8 - \
[ mail 0) = jLmainltems] {temho] < mainy_animals
v B Views = E D G
. .
Object List

The Object List is located on the right side of the page. It contains a list of all objects(tables and
views) in the database. You can drag and drop tables from the Object List to the Query Building
Area.

Query Building Area

The Query Building Area is the main area where the visual representation of query will appear.
This area allows you to define source database objects and derived tables, set links between them
and set properties of tables and links.

Columns Pane

The Columns Pane is below the query building area. It is intended for performing all required
operations with query output columns and expressions. Here you can define field aliases, sort and
group out and build criteria.

The page control above the query building area will allow you to switch between the main query
and sub-queries.

The small area in the corner of the query building area with letter "Q" is the union sub- query

handling control. Here you may add new union sub-queries and perform all necessary operations
on them.
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Building SQL queries using the Query Builder

To build an SQL query, follow the next steps:

1. Go to the SQL Builder page.

2. Drag and drop objects from the Object list in the Query Building Area.

3. Create joins by dragging a field from an object to another field, then set their properties by
selecting Properties from the join drop-down menu.

4. Specity which fields you want in your query by selecting them with a checkbox next to field
name.

5. Use the Columns pane to specify sort types, grouping, function or select criteria.

6. To build the query, select Build SQL from the Query Building Area popup menu, or press F4.
The generated query will be displayed on the SQL page.

7. To build and execute the query, select Build and Execute SQL from the Query Building Area
popup menu, or press F6. The generated query and the result set will be displayed on the SQL

page.
Editing object properties

You may change the properties of each object added to the query by right clicking the object and
selecting the Edit... item from the drop-down menu or simply by double- clicking the object's
header.

ke ain |
i dbo.Cate txl
RE ; Remove
s I
L] CategoryMame &, 1i0fit Object Height
E D escription

Datasource Properties il

Ohject
IdbD.EategDries

plias |l

' 0K X Cancel |

Joining tables
To create a link between two objects (i.e. join them) you should select the field by which you want

to link an object with another and drag it to the corresponding field of another object. After you
finish dragging, a line will appear between the linked fields.
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D %

T -

[] Custarner D m 't =l=l
[] EmnployeelD ool L]

[] OrderDate [ OrderlD

[ RequiredD ate L] ProductiD

[ ShippedD ate L1 UnitPrice

[ Shipvia L] Gluantity

[] Freight [ Dizcount

] ShipMarme

[ Ship&ddress
] ShipCity

[] ShipR egion

[] ShipPostalCode
[ ShipCourtry

The join type created by default is INNER JOIN, i.e. only matching records of both tables will be
included in resulting dataset. To define other types of joins you should right click the link and
select the Edit... item from the drop down menu or simply double-click it to open the Link
Properties dialog. This dialog allows you to define join type and other link properties.

25 dbo.Orders JSIE]

®

[] Orderl D —

] Ciztomend D

L] EmployeelD Remove

[] OrderDrate

E RequiredD ate D
ShippedD ate AILETIEE

] Shipiia L) Quaritity

] Freight [] Discount

[ ShipM ame

[] Ship&ddress

[ ShipCity

[] ShipRegion

[ ShipPostalCode

[] ShipCountny

Link Properties |

Left object Right abject
Iu:ll:u:u.Dru:Iers Iu:ll:u:u.[Dru:Ier Dietails]

[T Select All From Left Select All From Right [

Left calumn Right colurmn

[OrderD B =] [orderD

& OF X Cancel |

To remove a link between objects, right-click the link line and select the Remove item from the
drop-down menu.

Selecting output fields
The easiest way to add a field to the list of query output fields is to check the checkbox at the left

of field name in the Query Building Area. To include all the fields of an object you should click the
checkbox at the left of the asterisk item of an object.
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Another way is to select a field name from the drop-down list of the Expression column in the
Columns Pane. And the most common way is to write any valid expression to the Expression

column in the Columns Pane.

To remove a field from the list of query output fields you should uncheck the checkbox at the left of
field name in the Query Building Area or you may remove it by unchecking the Output column

checkbox.

Such operations as removing lines from the Columns Pane or re-ordering output fields are

available by right clicking on the left-most gray column via the drop-down menu.

b air |

bx|
D x

OrderlD

[] Customer D

[] EmplayeelD
OrderDate

[1 RequiredD ate

[ ShippedD ate

reight
[] ShipM arne
[] Ship&ddress
[] ShipCity
[] ShipRegion
[] ShipPostalCode
[1 ShipCauntry

=

Output |Expression I.-’-'-.Iias Sort Type Sort Order IErDup By Criteria Or..
dbo. Orders. Orderd D E wpreszzion
¥ dbo.Orders OrdeDate E wpreszzion
< | i
Output field's aliases may be defined in the Alias column of the Columns Pane:
O ukput IE:-:pressi-:nn I.-’-‘-.Iias ISn:-rt Type ISn:-rt Order IGrn:nup By IEriteria Or..
e V| dbo.Orders OrderD 0ld E wprezsion
¥ dboOrders OrderDate E xpression
| ja
Sorting output fields

To define the sorting of output query fields you should use the Sort Type and Sort Order columns of



the Columns Pane.

The Sort Type column allows you to specify how the fields will be sorted - in Ascending or
Descending order.

The Sort Order column allows you to setup the order in which fields will be sorted, if there are
more than one field to sort specified.

To cancel sorting by some field you should clear the Sort Type column for this field.

O ukput IE:-:pressiu:un I.-'i'-.lias ISu:urt Type ISu:urt Order IGru:uup By IEriteria IEIr...
| M dboOrdersOrdedD | OId Court
¥  dbo.Orders OrderDate ODate Group E_l.,'LI

E wpressian -

B wihere —
[Group By
Having
Count X

4 | *

Defining criteria
To define criteria for the expression listed in the Columns Pane you must use the Criteria column.

Here you should write the criteria omitting the expression itself. For get the following criteria in
your query

WHERE (field >= 10) AND (field <= 20)
you should write

>=10 AND <=20

in the Criteria column.

You may specify several criteria for one expression using the Or... columns. These criteria will be
concatenated in the query with the OR operator.

Grouping output fields

To setup grouping by some of the fields and/or to define aggregate functions on grouped rows you
may use the Group by column.

You may select one of the following values for this column from the drop-down list:

- "Expression" and "Where": These values are used when no grouping is specified. The
"Expression" value is set when this expression is used as output expression in the SELECT clause
and nothing else. The "Where" value is set automatically when you define a criteria to this
expression that results in including this expression to the WHERE clause. Normally you shouldn't
care about value of the Group By column when you don't want to define grouping.

- "Group by" and "Having": These values are similar to the previous two, but used when you want
to define grouping in your query. In this case you should set the "Group by" value for all columns

you want to group by. Specifying criteria for the grouped columns will include these criteria in the
HAVING clause. If you want to include an expression ONLY in the HAVING clause you should set



the "Having" value in the Group By column for this expression.

- Aggregate functions (Count, Sum, etc): By selecting one of these values you will create an
aggregate expression for the value indicated in the Expression column.

O ukput IE:-:pressiu:un I.-'i'-.lias ISu:urt Type ISu:urt Order IGru:uup By IEriteria IEIr...

| M dboOrdersOrdedD | OId Court

[ ¥  dbo.Orders OrderDate ODate Group E_l.,'LI
E wpressian -

B wihere —
Having
Count X

4 | *

Adding a sub-query
You may add a sub-query as a part of expression or criteria using the Columns Pane.

To add a sub-query right click on the Expression or Criteria column of the Columns Pane and
select the Insert SubQuery item from the drop-down menu. Another way to add a sub-query is to
type "(Select)" in the Expression column and "= (Select)" or "In (Select)" or any other valid sub-
query expression in the Criteria column.

ElutputIE:-:pressinn I.-’-'-.Iias IS:::rt Type ISDrtDrder IGru:uup By IEriteria IEIr...
¥ dbo.Orders OrderlD Old Yhere

i |
¥  dboOrders OrderDate ODate Azoending 1 E =prezsion o g |
== i

e [

The corresponding tab will be created after adding a sub-query. This tab allows you to edit your
sub-query visually in the same way as you edit the main query. Another way to switch to the sub-
query tab is to press the ellipsis button of the cell where this sub-query is located. If this cell
contains more than one sub-query, the drop-down menu will be shown for you to select the right
sub-query.
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Fain (] Select dbo.[Order Details ... I Select dbo.[Order Subtata ... D

iz
=

Drder D

[ Custarmedl D
[ EmployeslD
OrderD ate

[[] RequiredD ate
[] ShippedD ate
O

[ Freight

[] ShipM ame

[] Shiptddress
[] ShipCity

[] ShipRegion

[] ShipPostalCode
[ ShipCoauriry

=lx|

Output |E:-:|:|ressi|:|n Aliaz Sart Type Sart Order | Group By IEriteria Or..
¥ dbo.Orders.OrderlD ald Wwhere ubtotalz]] z=-
¥ dbo.Orders OrderDate | 0D ate Azcending 1 Expression H
4 | i

Adding a derived table

You may add a derived table (a sub-query used in the FROM clause) using the Query Building

Area.

To add a sub-query right click on the Query Building Area and select the Add Derived Table item
from the drop-down menu.

b &t |

®

OrderlD

[ CustamerlD
[] EmploveelD
OrderDrate
[] ShippedD ate
O

1 Freight

[] ShipM arne
[] Ship&ddress
[ ShipCiky

[] ShipRegion

[] ShipCounty

[[] RequiredD ate

[] ShipPostalCode

Add Table

Edit...

! Union g

fa]

A new object representing newly created derived table will be added to the query building area of
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the main query. Also the corresponding tab will be created after adding a derived table. This tab
allows you to edit the sub-query visually in the same way as you edit the main query. Another way
to switch to the sub-query tab is to press the maximize button at the header of the object
representing this derived table.

T (l Select dbo. Products.® Fra ... []

&

l* [

OrderlD [EroductD

] Coistornel D [ PraductM ame
[] EmployeslD [] SupplierD
OrderD ate [] CategomlD
[ RequiredD ate [ QuarntitpPer nit
[] ShippedD ate [] UnitFrice

[] Shipia [] UnitzlnStack
[] Freight [1 Unitz0n0rder
[] ShipMame [] ReorderLevel
[ ShipAddress [] Dizgcontinued
[ ShipCity

[1 ShipRegion

[] ShipPostalCode

[] ShipCourtry

Working with unions

Working with union sub-queries is implemented via the small panel in the top-right corner of the
Query Building Area. Initially there is only one union sub-query labeled with letter "Q" in it. All
required operations are performed by means of the context drop- down menus.

- To add a new union sub-query select the New Union SubQuery menu item.

- To enclose a sub-query with brackets select the Enclose with Brackets menu item.

- To move a sub-query or a bracket to the top of the query (the topmost sub-query is the left one),
select the Move Backward menu item.

- To move a sub-query or a bracket to the bottom of the query, select the Move Forward menu
item.

- To remove a sub-query or a bracket select the Remove menu item.

- To change uniting operator select the needed operator from the list of supported operators from
the drop-down menu.

Union Sub-Query operations:
- Move Forward

- Move Backward

- New Union SubQuery

- Enclose With Brackets
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- Remove

la®ajea

Move Backward

Mew Union SubQuery
Enclose With Brackets
Remaove

Brackets operations:
- Move Forward
- Move Backward

- Remove Brackets

T eama

Move Forward
Move Backward

I Remove Brackets

Selecting uniting operator:

v Linion
Lnion Al

ffg an nap Q|
|

Generating Views using the Query Builder
You can use the Query Builder to generate views visually, without writing a line of SQL.
To create a view using the Query Builder, follow the next steps:

1. Build an SQL query using the Query Builder as described in the previous chapter.

2. Create a View from the generated SQL script.

Importing and Exporting Data

SQLite Expert provides tools for importing and exporting data from and to data sources, including
Excel, text files (CSV or TSV), SQLite databases, ADO data sources, or SQL scripts. Currently
the following operations are supported:

» Exporting data to Excel

» Exporting data to XML

» Exporting data to JSON

» Exporting data to a text file
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» Importing data from a text file

» For transfering data between SQLite, ADO and SQL scripts. use the Data Transfer Wizard

» Copying tables between databases using the clipboard

Exporting data to Excel

To export data from a grid to Excel, select Export to Excel from the grid pop-up menu. You will
be prompted to select the destination file name.

Exporting data to XML

To export data from a grid to an XML file, select Export to XML from the grid pop-up menu. You
will be prompted to select the destination file name.

Exporting data to JSON

To export data from a grid to a JSON file, select Export to JSON from the grid pop-up menu.
You will be prompted to select the destination file name.

Exporting data to HTML

To export data from a grid to an HTML file, select Export to HTML from the grid pop-up menu.
You will be prompted to select the destination file name.

Exporting data to Open Document Spreadsheet (ODS)
To export data from a grid to Open Document Spreadsheet (ODS), select Export to Open

Document Spreadsheet (ODS) from the grid pop-up menu. You will be prompted to select the
destination file name.

Exporting data to SQL

To export data from a grid to an SQL script, select Export to SQL from the grid pop-up menu.
You will be prompted to select the destination file name.

Exporting data to a text file
To export data from a grid to a text file, follow the next steps:

1. Select Export to text file from the grid pop-up menu.

2. The 'Export text file' dialogs pops up. This allows you to choose the destination file name,
encoding and delimiter. The following delimiters are supported: comma, semicolon, tab and
custom.
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s Export To Text File (CSV, TSV) =

Destinaticn

File Mame:

biclife.csv

Encoding Delirniter

o Default AMSI code page o Comma

() ASCII i1 Semicolon

i) UTF-8 i) Tab

~ UTF-16le ) Other | |
1 UTF-16be

W Write encoding preamble

Log

Close

3. Choose the destination file, the encoding and the delimiter.

4. Click the 'Start' button to start the export process.

Importing data from a text file
To import data from a text file to a table in the current database, follow the next steps:
1. Select Import/Export » Import text file from the main menu.

2. The "Tmport text file' dialog pops up. This allows you to select the source file name, the
destination table and a few other options.
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4+ Import Text File (CSV, T5V) = 2

Source

File Marne:
Encoding Delimiter Destination Options
Default ANSI code page Comma MNew Table: Delete ewisting data
ASCI Semicolon hiolife Field names on first row
o) UTF-2 Tab o Buisting table:
UTF-16le o) Other: bilife o
UTF-16be
Log

Close

3. Select the text file name.

4. SQLite Expert will attempt to detect the delimiter used in the file (comma, semicolon or tab).
You may wish to change it to a different value if the auto-detect function is not accurate.

5. Select the destination table. If you wish to import the data in an existing table, check the
'Existing table' and select the destination table from the drop-down list. Otherwise, select New
table' and enter the name for the new table.

6. Select 'Delete existing data' if you wish to clear the data before importing the text file.

7. If you chose to import the text file into a new table, check 'Auto detect field types' if you want
SQLite Expert to try and guess the data type based on the data in the file. This option is slower as
it requires two passes through the text file. If you leave this option unchecked all the data will be
imported as CHAR.

8. Click the 'Start' button to start the import process.

Using the Data Transfer Wizard

The Data Transfer Wizard is a powerful tool to import or export your data quickly, and it allows
you to set all the import/export options for different files visually. Currently the following
operations are supported:

» Importing data from another SQLite database

» Importing data from a script
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» Importing data from an ADO data source

» Exporting data to another SQLite database

» Exporting data to a script

Importing data from another SQLite database
To import data into the selected database from another SQLite database, follow the next steps:

1. Select Import/Export » Data Transfer Wizard from the main menu. This pops up the Data
Transfer Wizard.

O W Data Transfer Wizard

Welcome

The Data Transfer Wizard is a powerful tool to impeort or export your data quickly, and it allows you to set all
the import/export options for different files visually, Currently the following operations are supported:

=» Transfer data between two 5CLite databases
» lmperting data from a script
» lmperting data from an ADO data source

» Exporting data to a script

Click Mext to continue.

http: ffwww.sgliteexpert. com

2. Click the Next button.
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Action

) Export
Export data from selected database (dbdemos(1))

© Import
Irport data into selected database (dbdemos(1])

3. Select 'Tmport data into the selected database'.

4. Click the Next button.
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Source

(@) SQlite database

Import data from another 50Lite database
(0 SQL Script

Irnport SOL script
" ADO data source

Import data from ADO data source

5. In the Source page, select 'SQLite database'.

6. Select the alias of the source database.
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SQlite database

Select the 5CLite database to import from
dbdemos

7. Click the Next button.

8. On the next page, select import options:
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@ % Data Transfer Wizard
Options

Empty destination objects first
Use this option to empty database chbjects that already exist.
¥ Drop destination objects first
Use this option to recreate database objects that already exist.
| Use transaction
lUse a transaction for the data transfer and rollback if any errors occur,

¥ Preserve ROWID
Preserve the value of ROWID when copying data between SCLite tables,

http: ffwww  sgliteexpert. com P Mext Cancel

9. Click the Next button.

10. On the next page, select the types of objects that you want to import:
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11. Click the Next button.

12. On the next page, select the individual objects that you want to import.
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Select objects to import

Mame Type

v [¥] animals Table
’ Copy table structure Structure
’ Copy constraints Constraints
‘... & idx_animals NAME Index

- || biolife Table

- ¥ clients Table

=[] country Table

custoly Table

customer Table

- || employee Tahle
events Table

= s -

13. Click the Next button.

14. The next page displays the Ready to start page.
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@ % Data Transfer Wizard

Ready to start

Click Mext to start the data transfer.
Click Cancel to exit.

Click Back to review or change any of your settings.

Mext Cancel

http: ffwww  sgliteexpert. com

15. If you are satisfied with your choices, click Next to start the data transfer. Otherwise, click the
Back button to change your choices.

16. During the data transfer, you have the option to cancel the operation by clicking the Cancel
button.
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Data transfer in progress

Create table: parts
Create indexes: parts
Drop table: reservat
Create table: reservat
Create indexes: reservat
Drop table: vendors
Create table: vendors
Drop table: venues
Create table: venues
Drop table: Wapux
Create table: Wapux
Copy data

Copy data

Table biclife: records copied: 28
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Q ¥ Data Transfer Wizard

Finish

The data transfer has ended. Click Finish to exit the wizard.

http:/fwww, sgliteexpert.com Einish Cancel

17. Click Finish to exit the wizard.

Importing data from a script

To import data into the selected database from an SQL script, follow the next steps:
1. Select Import/Export » Data Transfer Wizard from the main menu.

2. In the Action page, select 'Import data into the selected database'. Click Next.

3. In the Source page, select 'SQL Script'. Click Next.

4. Enter the file name for the script to import or use the file open dialog to select the script file.
Click Next;

5. On the encoding page, select the encoding of the source file, if it is different than the detected
encoding. Click Next.

6. On the Options page, select to use transaction. Click Next.

7. If you are satisfied with your choices, click Next to start the data transfer. Otherwise, click the
Back button to change your choices.

&. Click Finish to exit the wizard.
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Importing data from an ADO data source
To import data into the selected database from an ADO data source, follow the next steps:
1. Select Import/Export » Data Transfer Wizard from the main menu.

2. In the Action page, select 'Import data into the selected database'. Click Next.

3. In the Source page, select 'ADO Data Source'. Click Next.

4. Click the '.." button to open a standard dialog for building the ADO connection string.

Source of connection

() Use data link file

(21 Use connection string

|  Build..

QK [ | Cancel

5. After building the ADO connection string, click the Next button.

6. Select additional options.
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'.\!"f," ¥y Data Transfer Wizard

Options

[ | Empty destination objects first

Use this option to empty database objects that already exist.
Drop destination objects first

Use this option to recreate database chjects that already exist,

Use transaction

Use a transaction for the data transfer and rellback if any errors occur,

[] Prefix index name width table name

Use this option if index names are not unique in the source database.

http: ffwoww, sgliteexpert. com I Mext Cancel

7. On the next page, select the types of objects that you want to import, then click Next.
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[ Eal
@ % Data Transfer Wizard

Object types

Table structure
Table data

Indexes

http: ffwoww, sgliteexpert. com | [ ext | | Cancel J

8. Click the Next button.

9. On the next page, select the individual objects that you want to import.
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[ A % Data Transfer Wizard

Select objects to import

Mame Type | Selectall

= BasicRate _ ]
Copy table structure Structure . Unselect all
Copy records Data
PrimaryKey Index

http: /fwww. sqliteexpert. com ﬂm{t """"""  Cancel

10. Click the Next button.

11. If you are satisfied with your choices, click Next to start the data transfer. Otherwise, click the
Back button to change your choices.

12. During the data transfer, you have the option to cancel the operation by clicking the Cancel
button.

13. Click Finish to exit the wizard.

Exporting data to another SQLite database

To export data from the selected database to another SQLite database, follow the next steps:
1. Select Import/Export » Data Transfer Wizard from the main menu.

2. In the Action page, select 'Export data from the selected database'.

3. In the Destination page, select 'Another SQLite database’'.

4. Select the alias of the destination database.

5. Click the Next button.
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6. Select additional options:

'.\!"f," ¥y Data Transfer Wizard

Options

[ | Empty destination objects first

Use this option to empty database objects that already exist.
Drop destination objects first

Use this option to recreate database chjects that already exist,
Use transaction

Use a transaction for the data transfer and rellback if any errors occur,

Preserve ROWID
Preserve the value of ROWID when copying data between 5CLite tables,

http: ffwoww, sgliteexpert. com Mext Cancel

7. On the next page, select the types of objects that you want to export:
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i@ % Data Transfer Wizard

Object types

Table structure
Table data

Indexes

Constraints

Triggers

Views

Database properties

http: ffwoww, sgliteexpert. com | [ ext |[ Cancel J

8. Click the Next button.

9. On the next page, select the individual objects that you want to export.
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4= ¥, Data Transfer Wizard

Select objects to export

http: ffwoww, sgliteexpert. com

Mame Type N
=/ |+ Eanimals Table
v | Copy table structure Structure
+| Copy records Data e
v | Copy constraints Constraints
| iche_animals_MAME Index
+| |+ biclife Table
= || clients Table
v | Copy table structure Structure
+| Copy records Data
v| Copy constraints Constraints
+| || country Table
+| || custoly Table
+| || customer Table 3
S T Tows

Select all

Unselect all

Cancel

10. Click the Next button.

11. If you are satisfied with your choices, click Next to start the data transfer. Otherwise, click the

Back button to change your choices.

12. During the data transfer, you have the option to cancel the operation by clicking the Cancel

button.

13. Click Finish to exit the wizard.

Exporting data to a script

To export data from the selected database to an SQL script, follow the next steps:

1. Select Import/Export » Data Transfer Wizard from the main menu.

2. In the Action page, select 'Export data from selected database'.

3. In the Destination page, select 'SQL Script'.

4. Select the file name for the destination script. Click Next.

5. Select the file encoding, then click Next:
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[ Eal
@ % Data Transfer Wizard

SQL script encoding

7) Default ANSI code page
) ASCI

) UTF-8

) UTF-16le

) UTF-16be

Write encoding preamble

http: ffwoww, sgliteexpert. com |

6. Select additional options:
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(4 %y Data Transfer Wizard

Options

[ | Empty destination objects first

Use this option to empty database objects that already exist.
Drop destination objects first

Use this option to recreate database chjects that already exist,

Use transaction

Use a transaction for the data transfer and rellback if any errors occur,

Preserve ROWID
Preserve the value of ROWID when copying data between 5CLite tables,

Include column list
Include celumn list when saving data to S0L IMSERT statermnents,

http: ffwoww, sgliteexpert. com Mext Cancel

7. On the next page, select the types of objects that you want to export.
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i@ % Data Transfer Wizard

Object types

Table structure
Table data

Indexes

Constraints

Triggers

Views

Database properties

http: ffwoww, sgliteexpert. com | [ ext | | Cancel J

8. Click the Next button.

9. On the next page, select the individual objects that you want to export.
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4= ¥, Data Transfer Wizard
Select objects to export
Mame Type N Select all
= vganhﬂah Table
v | Copy table structure Structure Lpcelectal
+| Copy records Data e
v | Copy constraints Constraints
| iche_animals_MAME Index
+| || biclife Table
+ |« clients Table
= || country Table
v | Copy table structure Structure
v | Copy records Data
| Copy constraints Constraints
+| || custoly Table
+ |« customer Table
— [l Tl k-
http: /fwww, sgliteexpert. com Mext Cancel

10. Click the Next button.

11. If you are satisfied with your choices, click Next to start the data transfer. Otherwise, click the
Back button to change your choices.

12. During the data transfer, you have the option to cancel the operation by clicking the Cancel
button.

13. Click Finish to exit the wizard.

Copying tables between databases using the clipboard

To copy one or more objects (tables or views) between databases using the clipboard, follow the
next steps:

1. Select the source objects using the mouse or keyboard with CTRL or SHIFT operations, then
press CTRL-C or select Copy from the tree popup menu.

2. Select the destination database, then press CTRL-V or select Paste from the tree popup menu.

3. The selected objects will be copied in the destination database, using a nested transaction. If
any errors are encountered, the transaction is rolled back and no data will be copied.
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Another way to copy tables or views between databases is by using drag and drop operations.

Using Transactions

Beginning in version 2.0, SQLite supports transactions with rollback and atomic commit.
The optional transaction name is ignored. SQLite supports nested transactions starting with version
3.6.8.

» Starting a transaction

» Committing a transaction

» Rolling back a transaction

» Creating a Savepoint

» Releasing a Savepoint

» Rolling back to a Savepoint
Starting a transaction
To start a transaction in the selected database, select
Transaction » Start Transaction

from the main menu. Transactions can also be started manually by executing a BEGIN
[TRANSACTION] command in an SQL script.

Committing a transaction
To commit a transaction in the selected database, select
Transaction » Commit

from the main menu. An active transaction can also be committed manually by executing a
COMMIT [TRANSACTION] command in an SQL script.

Rolling back a transaction
To roll back a transaction for the selected database, select
Transaction » Rollback

from the main menu. An active transaction can also be rolled back manually by executing a
ROLLBACK [TRANSACTION] command in an SQL script.
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Creating a Savepoint
To create a savepoint in the selected database, select
Transaction » Savepoint

from the main menu. You will be prompted to enter the name of the new savepoint. A savepoint can
also be created manually by executing a SAVEPOINT command in an SQL script.

Releasing a Savepoint
To release a savepoint in the selected database, select
Transaction » Release...

from the main menu and then select the name of the savepoint to be released. A savepoint can also
be released manually by executing a RELEASE [SAVEPOINT] command in an SQL script.

Rolling back to a Savepoint

To roll back a transaction to an existing savepoint in the selected database, select

Transaction » Rollback to...

from the main menu, then select the name of the savepoint. This operation can also be performed
manually by executing a ROLLBACK [TRANSACTION] TO [SAVEPOINT] command in an
SQL script.

Extending SQLite Expert using Scripting

SQLite Expert provides an API that can be used to extend and enhance the application's
functionality with scripts written in Lua or Pascal. Simple scripts can be written without any extra
tools in the SQLite Expert user interface. The API allows scripts access to SQLite databases and
implement functionality not duplicated in the formal Lua or Pascal API.

To select the scripting language: use the Language combo box on the Scripting tab.

To load a script: use the Load script command in the scripting popup menu.

To save a script: use the Save script command in the scripting popup menu.

To execute a script: use the Execute command in the scripting popup menu. Errors encountered
while executing scripts are displayed in the Output tab.

» Scripting examples

» Lua scripting API

» Pascal scripting API




Scripting examples
Scripting example 1: display data

The following Lua script runs a query and displays the result on the Data tab:

database = sglitedatabase:new()
database:filename ("C:\\Program Files\\SQLite Expert\\Professional\\Data\

\dbdemos.db3")
database:connected (true)

query = sqglitequery:new ()
query:database (database)

query:sgl ("select * from customer")
query:active (true)

displaydata (query)

query:free ()

database:free ()

The same script in Pascal:

var
Database: TSQLiteDatabase;
Query: TSQLiteQuery;
begin
Database := TSQLiteDatabase.Create (nil);
Database.FileName := 'C:\Program Files\SQLite
Expert\Professional\Data\dbdemos.db3"';
Database.Connected := True;
Query := TSQLiteQuery.Create(nil);
Query.Database := Database;
Query.SQL := 'select * from customer';
Query.Open;
DisplayData (Query) ;
Query.Free;
Database.Free;

end.

Scripting example 2: display all table names in a database

The following Lua script displays all the tables in the database dbdemos.db3:

database = sglitedatabase:new ()
database:filename ("C:\\Program Files\\SQLite Expert\\Professional\\Data\

\dbdemos.db3")
database:open ()
query = sqglitequery:new()
query:database (database)
query:sql ("select * from sglite master where type = \"table\"")
query:open ()
query:first ()
while (query:eof() == false) do
print (query:getfield("name") :value (), "\n")

query:next ()



end
query:free ()

database:free ()

The same example in Pascal:

var
Database: TSQLiteDatabase;
Query: TSQLiteQuery;

begin

Database := TSQLiteDatabase.Create (nil);

Database.FileName := 'C:\Program Files\SQLite
Expert\Professional\Data\dbdemos.db3"';

Database.Connected := True;

Query := TSQLiteQuery.Create(nil);

Query.Database := Database;

Query.SQL := 'select * from sqglite master where type = "table"';

Query.Open;

while not Query.Eof do

begin
Writeln (Query.FieldByName ('name') .AsString);
Query.Next;

end;

DisplayData (Query) ;

Query.Free;

Database.Free;

end.

Scripting example 3: update field

The following script iterates through the employee table and increases the Salary field by 10% to
all employees:

database = sglitedatabase:new ()
database:filename ("C:\\Program Files\\SQLite Expert\\Professional\\Data\

\dbdemos.db3")

database:connected (true)

query = sqglitequery:new()

query:database (database)

query:sql ("select * from employee")

query:active (true)

query:first ()

while (query:eof() == false) do
query:edit ()
query:getfield('Salary') :asfloat (query:getfield('Salary')::asfloat() * 1.1)
query:post ()
query:next ()

end

displaydata (query)

query:free ()

database:free ()

The same example in Pascal:



var

Database: TSQLiteDatabase;
Query: TSQLiteQuery;
begin
Database := TSQLiteDatabase.Create (nil);

Database.FileName :=
Expert\Professional\Data\dbdemos.db3"';

Database.Connected := True;

Query := TSQLiteQuery.Create(nil);
Query.Database := Database;

Query.SQL := 'select * from employee';
Query.Open;

while not Query.Eof do
begin
Query.Edit;
Query.FieldByName ('Salary') .AsFloat
1.1;
Query.Post;
Query.Next;
end;
DisplayData (Query) ;
Query.Free;

Database.Free;
end.

Lua scripting API

The sqlitedatabase class

sglitedatabase:new ()

'C:\Program Files\SQLite

:= Query.FieldByName ('Salary') .AsFloat *

Creates and returns a new instance of a sqlitedatabase object.

sqlitedatabase:filename ([filename])

Sets or retrieves the value of the filename associated with the database object. The filename must

point to an existing SQLite3 database, or :memory: for opening an in- memory database.

sglitedatabase:connected([value])

When called with an argument, connects or disconnects the database to the filename set by
sqlitedatabase:filename(). Returns true if connected to the database.

sqlitedatabase:open/()

Connects to the database. Similar to sqlitedatabase:connected(true) except it does not return a

value.



sglitedatabase:close ()

Similar to sqlitedatabase:connected(false) except it does not return a value.

sqlitedatabase:execute (sql)

Executes an SQL statement in the current database.

sglitedatabase:begintransaction ()

Starts a transaction.

sqlitedatabase:commit ()

Commits the current transaction.

sqglitedatabase:rollback ()

Rolls back the current transaction.

sqlitedatabase:intransaction|()

Returns true if a transaction is active, and false otherwise.

sglitedatabase: free ()

Destroys the object and frees its associated memory.

The sqlitequery class

sqglitequery represents a dataset with a result set that is based on an SQL statement.

sqlitequery:new ()

Creates and returns a new instance of a sqlitequery object.

sglitequery:database ([sglitedatabase])



When called with an argument, it binds the query with the sqlitedatabase object. Returns the
associated sqlitedatabase object.

sglitequery:active ([value])

When called with a boolean argument: opens or closes the query depending on whether value is
true or false. Returns true if active, false if not.

sglitequery:open/()
Opens the query by executing the SQL statement. Similar to sqlitequery:active (true) .

If the SQL statement returns a cursor the following functions can be used to iterate through the
result set: first, last, next, prior, eof, bof.

sqlitequery:close()

Closes the query.

sglitequery:eof ()

Test eof (end of file) to determine if the dataset is positioned at the last record.

sqlitequery:bof ()

Test bof (beginning of file) to determine if the dataset is positioned at the first record.

sglitequery:first()

Moves to the first record in the dataset.

sqlitequery:last()

Moves to the last record in the dataset.

sglitequery:next ()

Moves to the next record in the dataset.



sqglitequery:prior ()

Moves to the previous record in the dataset.

sqlitequery:edit()

Enables editing of data in the dataset.

sglitequery:post()

Writes the modified record to the database.

sqlitequery:insert()

Inserts a new, empty record in the dataset.

sglitequery:delete ()

Deletes the active record and positions the dataset on the next record.

sqlitequery:cancel ()

Cancels modifications to the active record if those changes are not yet posted.

sglitequery:recordcount ()

Indicates the total number of records associated with the dataset. Note: the value returned by this
function is only valid after reaching the last record in the dataset.

sqlitequery:recno ()

Indicates the active record in the dataset.

sglitequery:fieldcount ()

Indicates the number of field components associated with the dataset.



sglitequery:getfield([value])

Finds a field based on its name (if value is a string) or its index (if value is an integer
number). Returns a sqlitefield object, or null if the field was not found.

sqlitequery:sql ([value])

Sets or retrieves the text of the SQL statement to execute for the query.

sglitequery: free ()

Destroys the object and frees its associated memory.

The sqlitefield class
sglitefield:name ()

Returns the name of the field.

sqlitefield:value([value])

Sets or retrieves the value of the field in the current record, as string. To set the value of the field,
the dataset must be in the Edit mode, set by a previous call to Insert or Edit.

sqglitefield:asstring([value])

Same as sqlitefield:value ([value]) : sets or retrieves the value of the field in the
current record, as string. To set the value of the field, the dataset must be in the Edit mode, set by a
previous call to Insert or Edit.

sqglitefield:asfloat([value])

Sets or retrieves the value of the field in the current record, as a floating point number. To set the
value of the field, the dataset must be in the Edit mode, set by a previous call to Insert or Edit.

sqlitefield:asboolean([value])

Sets or retrieves the value of the field in the current record, as a boolean value. To set the value of
the field, the dataset must be in the Edit mode, set by a previous call to Insert or Edit.



sqglitefield: fullsqgltype ()

Returns the full declared type of the field including sqltype, size and precision.

sqlitefield:sqltype ()

Returns the field declared type.

sqglitefield:size()

Returns the field size.

sqgqlitefield:precision()
Returns the field precision.
Pascal scripting API
The TSQLiteDatabase class

constructor Create (AOwner: TComponent)

Creates and returns a new instance of a TSQLiteDatabase object.

property FileName: string;

Sets or retrieves the value of the filename associated with the database object. The filename must
point to an existing SQLite3 database, or :memory: for opening an in- memory database.

property Connected: Boolean;

When called with an argument, connects or disconnects the database to the filename set by the
FileName property. Returns True if connected to the database.

procedure Open;

Connects to the database. Similar to calling Connected (True) except it does not return a
value.

procedure Close;



Disconnects from database. Similar to calling Connected (False) except it does not return a
value.

procedure Execute (const SQL: string);

Executes an SQL statement in the current database.

procedure BeginTransaction;

Starts a transaction.

procedure Commit;

Commits the current transaction.

procedure Rollback;

Rolls back the current transaction.

property InTransaction: Boolean;

Returns True if a transaction is active, and False otherwise.

procedure Free;

Destroys the object and frees its associated memory.

The TSQLiteQuery class

TSQLiteQuery represents a dataset with a result set that is based on an SQL statement.

constructor Create (AOwner: TComponent) ;

Creates and returns a new instance of a sqlitequery object.

property Database: TSQLiteDatabase;



Specifies the database object associated with the query.

property Active: Boolean;

Specifies whether or not the dataset is open.

procedure Open;
Opens the query by executing the SQL statement. Similar to calling
Active := True.

If the SQL statement returns a cursor the following functions and properties can be used to iterate
through the result set: First, Last, Next, Prior, Eof, Bof.

procedure Close;

Closes the query.

property Eof: Boolean;

Test eof (end of file) to determine if the dataset is positioned at the last record.

property Bof: Boolean;

Test bof (beginning of file) to determine if the dataset is positioned at the first record.

procedure First;

Moves to the first record in the dataset.

procedure Last;

Moves to the last record in the dataset.

procedure Next;

Moves to the next record in the dataset.



procedure Prior;

Moves to the previous record in the dataset.

procedure Edit;

Enables editing of data in the dataset.

procedure Post;

Writes the modified record to the database.

procedure Insert;

Inserts a new, empty record in the dataset.

procedure Delete;

Deletes the active record and positions the dataset on the next record.

procedure Cancel;

Cancels modifications to the active record if those changes are not yet posted.

property RecordCount: Integer;

Indicates the total number of records associated with the dataset. Note: the value returned by this
property is only valid after reaching the last record in the dataset.

property RecNo: Integer;

Indicates the active record in the dataset.

property FieldCount: Integer;

Indicates the number of field components associated with the dataset.



function FieldByName (const Value: string): TField;

Finds a field based on its name. Returns a TField object, or nil if the field was not found.

function Fields (const Index: Integer): TField;

Finds a field based on its index. Returns a TField object. An 'index out of range' error occurs if
the Index is < 0 or >= FieldCount.

property SQL: string;

Sets or retrieves the text of the SQL statement to execute for the query.

procedure Free;

Destroys the object and frees its associated memory.

The TField class
property FieldName: string;

Returns the name of the field.

property Value: Variant;

Sets or retrieves the value of the field in the current record, as a variant. To set the value of the
field, the dataset must be in the Edit mode, set by a previous call to Insert or Edit.

property AsString: string;

Sets or retrieves the value of the field in the current record, as string. To set the value of the field,
the dataset must be in the Edit mode, set by a previous call to Insert or Edit.

property AsFloat: Double;

Sets or retrieves the value of the field in the current record, as a floating point number. To set the
value of the field, the dataset must be in the Edit mode, set by a previous call to Insert or Edit.



property AsBoolean: Boolean;

Sets or retrieves the value of the field in the current record, as a boolean value. To set the value of
the field, the dataset must be in the Edit mode, set by a previous call to Insert or Edit.

property Size: Integer;

Indicates the size used in the definition of the physical database field for data types that support
different sizes.

Data types

SQLite3 allows the user to declare any data type, but each value stored in an SQLite database (or
manipulated by the database engine) has one of the following storage classes:

( NULL. The value is a NULL value.

( INTEGER. The value is a signed integer, stored in 1, 2, 3, 4, 6, or 8 bytes depending on the
magnitude of the value.

( REAL. The value is a floating point value, stored as an 8-byte IEEE floating point number.

( TEXT. The value is a text string, stored using the database encoding (UTF-8, UTF-16BE or
UTF-16-LE).

( BLOB. The value is a blob of data, stored exactly as it was input.

SQLite Expert supports the following predefined data types:

Declared type Mapped to internal  |[Description
|data type

DEC Float Floating-point numeric field (8 bytes)
DECIMAL Float Floating-point numeric field (8 bytes)
DOUBLE Float Floating-point numeric field (8 bytes)
DOUBLE PRECISION  [Float Floating-point numeric field (8 bytes)
FLOAT Float Floating-point numeric field (8 bytes)
NUMERIC Float Floating-point numeric field (8 bytes)
REAL Float Floating-point numeric field (8 bytes)
INT Largeint 64-bit integer field

INTEGER Largeint 64-bit integer field

SMALLINT Largeint 64-bit integer field




TINYINT Largeint 64-bit integer field

(WORD Largeint 64-bit integer field

AUTOINC Largeint 64-bit integer field

BIGINT Largeint 64-bit integer field

LARGEINT Largeint 64-bit integer field

INT64 Largeint 64-bit integer field

CHAR 'WideString 'Wide string field

[VARCHAR WideString Wide string field

VARCHAR?2 WideString Wide string field

TEXT WideString Wide string field

DATETEXT WideString Wide string field

NCHAR WideString Wide string field

NVARCHAR 'WideString Wide string field

NVARCHAR?2 WideString Wide string field

INTEXT 'WideString Wide string field

CURRENCY |Currency Money field (8 bytes)

MONEY |Currency Money field (8 bytes)
SMALLMONEY |Currency Money field (8 bytes)

BLOB Blob Binary Large Object field

RAW Blob Binary Large Object field
BINARY Blob Binary Large Object field
[VARBINARY Blob Binary Large Object field
CLOB 'WideMemo Text wide memo field

MEMO WideMemo Text wide memo field

DATE Date Date field (Borland TDateTime)
TIME Time Time field (Borland TDateTime)
DATETIME DateTime Date and time field (Borland TDateTime)




TIMESTAMP DateTime Date and time field (Borland TDateTime)

BOOLEAN Boolean Boolean field

GRAPHIC IGraphic IGraphic field

Note: The integral part of a Date, Time or DateTime value is the number of days that have passed
since 12/30/1899. The fractional part of the Date, Time or DateTime value is fraction of a 24 hour
day that has elapsed. SQLite Expert will store the Date, Time and DateTime fields in the database
in the format 'yyyy-mm-dd hh-mm-ss.sss' but will recognize the date and time fields stored in the
Borland DateTime format.

In addition to the predefined data types, SQLite Expert allows the user to declare custom data
types. That is, you can add your own declared types but they have to map internally to one of the
known data types shown in the above table. To change the internal data mapping please see

Changing options.

For more information about SQLite3 data types, please consult the SQLite3 documentation.

Changing options

To change some of the program options, choose
Tools » Options

from the main menu.


http://www.sqlite.org/
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"2 Options

General

Editors

Designer

Fonts

Data

Code generation
Code completion
S5QLite library
Type mappings
File associations

Updates

Reset

| General | Editors | Designer | Fonts | Data | Grids IC()de generation | Code completion | SQLite lit

Grids

Auto refresh data V

Show Filter 2

Cell Select Mode []

Cell Auto Height 2

Immediate editor

Show Cell Hints []

Show Images V

Show edit buttons

Show Null Values 2

Show hyperlinks (slower)

Show record numbers

Show "rowid” on Data tab

Thumb Tracking V

Dbl-click opens record editor V

Highlight values having possibly incorrect storage classes V

Max BLOB size to load in grids (bytes) 100000 :i:

Horizontal Alignment Default )

Wertical Alignment Default )
oK Cancel

The following options are configurable:

General options

o the look and feel of the user interface

o toolbar on/off

o tree panel options like object grouping or level of detail

o startup options

Editor options

o auto-save files
o word wrap
o tab width

Fonts

o default font - used everywhere except the code editors
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o fixed font - used in the code editors

Data options

o use default alias
o display the results in grid or as text
o maximum text size to be displayed

Grid options

show filter

cell select mode

cell auto height

show cell hints

show images

show edit buttons

show null values (as <null>)

show hyperlinks

show record numbers

show "rowid" on Data tab

dbl-click opens record editor

highlight values having possibly incorrect storage classes
max BLOB size to load in grids (bytes)
horizontal and vertical alignment

O 0O O O O O O O O o o o o0 o

Code Generation options

o capitalization
o quote characters

Code completion options

enable code completion

enable code completion auto-invoke
auto-invoke delay

enable code template completion
code templates

O O O O O

SQLite library

Type mappings

This allows changing the internal mapping of data types. For more information about the type
mappings, see Data types.



SQLite Expert 5.5

File associations

This allows changing the file extensions associated with the application. By default the following
extensions are associated: .db, .db3, .sqlite, .tooldb.

Updates

This allows changing the number of days between checks for updates.

Getting Help

» Integrated Help

» SQLite Expert on the Web

» SQLite on the Web

» Sending feedback
Integrated Help

The help file that comes with SQLite Expert contains complete documentation of all aspects of the
program.

To display Help:

Choose Help » Contents or press F1.

SQLite Expert on the Web

SQLite Expert web site is a great resource for up-to-date information on SQLite Expert and other
products. Through the SQLite Expert web site, you can find:

( technical support
( a knowledge base

( news and tips
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To access the SQLite Expert web site, choose
Help » SQLite Expert Home Page

or visit http://www.sqgliteexpert.com.

SQLite on the Web

SQLite web site is a frequently updated website with links, tips, news, and downloads for SQLite
users around the world. Through the SQLite web site, you can find:

( the latest version of the database engine sqlite3.dll
( the complete SQLite documentation
( technical support on SQLite
( a knowledge base
( news and tips
( a mailing list
To access the SQLite web site, choose

Help » SQLite Home Page or visit www.sqlite.org.

To access the SQLite online documentation, choose

Help » SQLite Online Help.

Sending feedback

To send us your suggestions, ideas, and bug reports about SQLite Expert, choose

Help » Send Feedback

from the main menu. This command launches the default mail program which allows you to send
email to support@sqliteexpert.com.

Known Issues

Invalid field names in views

If you create a view from multiple tables using quoted identifiers and do not use field aliases, the
generated view has invalid field names. This is a known issue in SQLite, not in SQLite Expert. For
more information please consult the SQLite bug list:


http://www.sqliteexpert.com
http://www.sqlite.org
http://www.sqlite.org
mailto:support@sqliteexpert.com?subject=SQLite Expert feedback

http://www.sqlite.org/src/wiki?name=Bug+Reports

To work around this issue, use field aliases when generating a view. The integrated Query
Builder automatically generates unique field aliases so the views created using the Query Builder
are not affected by this problem.

Syntax error in queries using databasename.tablename.*

The following query
select databasename.tablename.* from databasename.tablename
returns:

near "*": syntax error

However, the following query returns no error:

select databasename.tablename.fieldname from
databasename.tablename

This is a SQLite error and it has been reported to www.sqlite.org (ticket 4037).


http://www.sqlite.org/src/wiki?name=Bug Reports
http://www.sqlite.org/cvstrac/tktview?tn=4037
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